]> git.pld-linux.org Git - packages/perl-Gnome2-Print.git/blob - perl-Gnome2-Print.spec
c38d4f09baaa67b8f108e5a0ddcce042d22af759
[packages/perl-Gnome2-Print.git] / perl-Gnome2-Print.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (requires X server)
4 #
5 %define         pnam    Gnome2-Print
6 Summary:        Perl interface to the GNOME Print libraries
7 Summary(pl.UTF-8):      Interfejs perlowy do bibliotek GNOME Print
8 Name:           perl-Gnome2-Print
9 Version:        1.001
10 Release:        1
11 License:        LGPL v2+
12 Group:          Development/Languages/Perl
13 Source0:        https://downloads.sourceforge.net/gtk2-perl/%{pnam}-%{version}.tar.gz
14 # Source0-md5:  67ae821c4b7cb9046513a3944cd37e9b
15 URL:            http://gtk2-perl.sourceforge.net/
16 BuildRequires:  libgnomeprintui-devel >= 2.2.0
17 BuildRequires:  perl-ExtUtils-Depends >= 0.1
18 BuildRequires:  perl-ExtUtils-PkgConfig >= 1.03
19 BuildRequires:  perl-Glib-devel >= 1.120
20 BuildRequires:  perl-Gtk2-devel >= 1.120
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  pkgconfig
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRequires:  rpmbuild(macros) >= 1.745
25 Requires:       libgnomeprintui >= 2.2.0
26 Requires:       perl-Glib >= 1.120
27 Requires:       perl-Gtk2 >= 1.120
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 The Gnome2::Print Perl module allows a Perl developer to use the GNOME
32 Printing libraries with Gtk2-perl.
33
34 Note: this module is deprecated and no longer maintained.
35
36 %description -l pl.UTF-8
37 Moduł Perla Gnome2::Print umożliwia programistom perlowym korzystanie
38 z bibliotek GNOME Print wraz z Gtk2-perl.
39
40 Uwaga: ten moduł jest przestarzały i nie jest już utrzymywany.
41
42 %package devel
43 Summary:        Development files for Perl Gnome2-Print bindings
44 Summary(pl.UTF-8):      Pliki programistyczne wiązań Gnome2-Print dla Perla
45 Group:          Development/Languages/Perl
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       libgnomeprintui-devel >= 2.2.0
48 Requires:       perl-Cairo-devel
49 Requires:       perl-Glib-devel >= 1.120
50 Requires:       perl-Gtk2-devel >= 1.120
51
52 %description devel
53 Development files for Perl Gnome2-Print bindings.
54
55 %description devel -l pl.UTF-8
56 Pliki programistyczne wiązań Gnome2-Print dla Perla.
57
58 %prep
59 %setup -q -n %{pnam}-%{version}
60
61 %build
62 %{__perl} Makefile.PL \
63         INSTALLDIRS=vendor
64
65 %{__make} \
66         CC="%{__cc}" \
67         OPTIMIZE="%{rpmcflags}"
68
69 %{?with_tests:%{__make} test}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} pure_install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Gnome2/Print/*.pod
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc AUTHORS ChangeLog NEWS README
85 %{perl_vendorarch}/Gnome2/Print.pm
86 %dir %{perl_vendorarch}/Gnome2/Print
87 %{perl_vendorarch}/Gnome2/Print/Config
88 %{perl_vendorarch}/Gnome2/Print/Font
89 %dir %{perl_vendorarch}/auto/Gnome2/Print
90 %attr(755,root,root) %{perl_vendorarch}/auto/Gnome2/Print/Print.so
91 %{_mandir}/man3/Gnome2::Print*.3pm*
92
93 %files devel
94 %defattr(644,root,root,755)
95 %{perl_vendorarch}/Gnome2/Print/Install
This page took 0.094141 seconds and 3 git commands to generate.