]> git.pld-linux.org Git - packages/perl-Getopt-Declare.git/blob - perl-Getopt-Declare.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Getopt-Declare.git] / perl-Getopt-Declare.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Getopt
6 %define         pnam    Declare
7 Summary:        Getopt::Declare - Declaratively Expressed Command-Line Arguments via Regular Expressions
8 Summary(pl.UTF-8):      Getopt::Declare - wyrażone deklaracyjnie przez wyrażenia regularne argumenty linii polecenia
9 Name:           perl-Getopt-Declare
10 Version:        1.14
11 Release:        1
12 License:        Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  7ed52d0279abcb34c366369af8ac8cb8
16 Patch0:         %{name}-paths.patch
17 URL:            http://search.cpan.org/dist/Getopt-Declare/
18 BuildRequires:  perl-Parse-RecDescent
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Getopt::Declare is yet another command-line argument parser, one which
26 is specifically designed to be powerful but exceptionally easy to use.
27
28 %description -l pl.UTF-8
29 Getopt::Declare jest jeszcze jednym parserem argumentów linii poleceń,
30 o wielkich możliwościach, a jednocześnie wyjątkowo łatwym w użyciu.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34 %patch0 -p1
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make}
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 cp -p demos/demo* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorlib}/Getopt/Declare.pm
59 %{_mandir}/man3/*
60 %dir %{_examplesdir}/%{name}-%{version}
61 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*
This page took 0.082197 seconds and 3 git commands to generate.