]> git.pld-linux.org Git - packages/perl-GTop.git/blob - perl-GTop.spec
- %description url unification
[packages/perl-GTop.git] / perl-GTop.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4                         # require /proc access
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    GTop
8 Summary:        GTop - Perl interface to libgtop
9 Summary(pl):    GTop - interfejs perlowy do libgtop
10 Name:           perl-GTop
11 Version:        0.13
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
17 # Source0-md5:  bc2fa8e43fb607a5a64e36b9a2661751
18 BuildRequires:  libgtop-devel >= 2.0
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  pkgconfig
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This package is a Perl interface to libgtop:
26 <http://home-of-linux.org/gnome/libgtop/>.
27
28 See also: Stas Bekman's Apache::VMonitor
29 <http://www.cpan.org/modules/by-module/Apache/>.
30
31 %description -l pl
32 Ten pakiet jest perlowym interfejsem do libgtop:
33 <http://home-of-linux.org/gnome/libgtop/>.
34
35 Warto zobaczyæ tak¿e Apache::VMonitor Stasa Bekmana:
36 <http://www.cpan.org/modules/by-module/Apache/>.
37
38 %prep
39 %setup -q -n %{pdir}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %{perl_vendorarch}/*.pm
61 %{perl_vendorarch}/%{pdir}
62 %dir %{perl_vendorarch}/auto/%{pdir}
63 %attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/*.so
64 %{perl_vendorarch}/auto/%{pdir}/*.bs
65 %dir %{perl_vendorarch}/auto/%{pdir}/Server
66 %attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/Server/*.so
67 %{perl_vendorarch}/auto/%{pdir}/Server/*.bs
68 %{_mandir}/man3/*
This page took 0.078167 seconds and 4 git commands to generate.