]> git.pld-linux.org Git - packages/perl-GTop.git/blob - perl-GTop.spec
- converted to UTF-8
[packages/perl-GTop.git] / perl-GTop.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4                         # require /proc access
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    GTop
8 Summary:        GTop - Perl interface to libgtop
9 Summary(pl.UTF-8):   GTop - interfejs perlowy do libgtop
10 Name:           perl-GTop
11 Version:        0.15
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/GTop/%{pdir}-%{version}.tar.gz
17 # Source0-md5:  049553661f8ceb7fa93517e8ed68f712
18 Patch0:         %{name}-error_h.patch
19 BuildRequires:  libgtop-devel >= 2.0
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  pkgconfig
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This package is a Perl interface to libgtop:
27 <http://home-of-linux.org/gnome/libgtop/>.
28
29 See also: Stas Bekman's Apache::VMonitor
30 <http://www.cpan.org/modules/by-module/Apache/>.
31
32 %description -l pl.UTF-8
33 Ten pakiet jest perlowym interfejsem do libgtop:
34 <http://home-of-linux.org/gnome/libgtop/>.
35
36 Warto zobaczyć także Apache::VMonitor Stasa Bekmana:
37 <http://www.cpan.org/modules/by-module/Apache/>.
38
39 %prep
40 %setup -q -n %{pdir}-%{version}
41 %patch0 -p1
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make} \
47         OPTIMIZE="%{rpmcflags}"
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %{perl_vendorarch}/*.pm
63 %{perl_vendorarch}/%{pdir}
64 %dir %{perl_vendorarch}/auto/%{pdir}
65 %attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/*.so
66 %{perl_vendorarch}/auto/%{pdir}/*.bs
67 %dir %{perl_vendorarch}/auto/%{pdir}/Server
68 %attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/Server/*.so
69 %{perl_vendorarch}/auto/%{pdir}/Server/*.bs
70 %{_mandir}/man3/*
This page took 0.098578 seconds and 4 git commands to generate.