]> git.pld-linux.org Git - packages/perl-GD-SecurityImage.git/blob - perl-GD-SecurityImage.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-GD-SecurityImage.git] / perl-GD-SecurityImage.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    GD
6 %define pnam    SecurityImage
7 Summary:        GD::SecurityImage - Security image (captcha) generator
8 Summary(pl.UTF-8):      GD::SecurityImage - generator obrazków zabezpieczających (captcha)
9 Name:           perl-GD-SecurityImage
10 Version:        1.71
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/GD/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  0f8be735452d733e675c77d70c0cfea7
17 URL:            http://search.cpan.org/dist/GD-SecurityImage/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-GD
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _noautoreq      'perl(Image::Magick)'
27
28 %description
29 The (so called) "Security Images" are so popular. Most Internet 
30 software use these in their registration screens to block robot
31 programs (which may register tons of fake member accounts). Security
32 images are basicaly, graphical CAPTCHAs (Completely Automated Public
33 Turing Test to Tell Computers and Humans Apart). This module gives you
34 a basic interface to create such an image. The final output is the
35 actual graphic data, the MIME type of the graphic and the created
36 random string.
37
38 The module also has some "styles" that are used to create the
39 background of the image.
40
41 If you are an Authen::Captcha user, see GD::SecurityImage::AC
42 for migration from Authen::Captcha to GD::SecurityImage.
43
44 %description -l pl.UTF-8
45 (Tak zwane) obrazki zabezpieczające ("Security Images") są bardzo
46 popularne. Większość oprogramowania w Internecie używach na ekranach
47 rejestracji do blokowania robotów (które mogłyby zarejestrować tysiące
48 fałszywych kont). Obrazki zabezpieczające to zasadniczo graficzne
49 CAPTCHA (Completely Automated Public Turing Test to Tell Computers and
50 Humans Apart - w pełni zautomatyzowane publiczne testy Turinga
51 odróżniające komputery od ludzi). Ten moduł udostępnia podstawowy
52 interfejs do tworzenia takich obrazków. Ostateczne wyjście to właściwe
53 dane graficzne, typ MIME danych graficznych i utworzony ciąg losowy.
54
55 Moduł ma także trochę "styli", służących do tworzenia tła obrazka.
56
57 Użytkownicy modułu Authen::Captcha mogą obejrzeć opis
58 GD::SecurityImage::AC w celu migracji z Authen::Captcha na
59 GD::SecurityImage.
60
61 %prep
62 %setup -q -n %{pdir}-%{pnam}-%{version}
63
64 %build
65 %{__perl} Makefile.PL \
66         INSTALLDIRS=vendor
67 %{__make}
68
69 %{?with_tests:%{__make} test}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
78 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc Changes README
86 %{perl_vendorlib}/GD/*.pm
87 %{perl_vendorlib}/GD/SecurityImage
88 %{_mandir}/man3/*
89 %{_examplesdir}/%{name}-%{version}
This page took 0.093343 seconds and 4 git commands to generate.