]> git.pld-linux.org Git - packages/perl-Find-Lib.git/blob - perl-Find-Lib.spec
- up to 1.04
[packages/perl-Find-Lib.git] / perl-Find-Lib.spec
1 #
2 # TODO: - fix "make test"
3 #       - pl
4 #
5 # Conditional build:
6 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
7 %bcond_with     tests           # do not perform "make test"
8 #
9 %include        /usr/lib/rpm/macros.perl
10 %define         pdir    Find
11 %define         pnam    Lib
12 Summary:        Find::Lib - helper to smartly find libs to use in the filesystem tree
13 Name:           perl-Find-Lib
14 Version:        1.04
15 Release:        1
16 # same as perl
17 License:        GPL v1+ or Artistic
18 Group:          Development/Languages/Perl
19 Source0:        http://search.cpan.org/CPAN/authors/id/Y/YA/YANNK/%{pdir}-%{pnam}-%{version}.tar.gz
20 # Source0-md5:  bf5619b4ba1945320eccef69b028c453
21 URL:            http://search.cpan.org/dist/Find-Lib/
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Helper to smartly find libs to use in the filesystem tree.
29
30 %prep
31 %setup -q -n %{pdir}-%{pnam}-%{version}
32
33 %build
34 %{__perl} Makefile.PL \
35         INSTALLDIRS=vendor
36
37 %{__make}
38
39 %{?with_tests:%{__make} test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__make} pure_install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc Changes README
53 %{_mandir}/man3/Find::Lib.3pm*
54 %dir %{perl_vendorlib}/Find
55 %{perl_vendorlib}/Find/Lib.pm
This page took 0.095448 seconds and 4 git commands to generate.