]> git.pld-linux.org Git - packages/perl-Find-Lib.git/blob - perl-Find-Lib.spec
- added to PLD
[packages/perl-Find-Lib.git] / perl-Find-Lib.spec
1 #
2 # TODO: - fix "make test"
3 #       - pl
4 #
5 # Conditional build:
6 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
7 %bcond_with     tests           # do not perform "make test"
8 #
9 %include        /usr/lib/rpm/macros.perl
10 %define         pdir    Find
11 %define         pnam    Lib
12 Summary:        Find::Lib - helper to smartly find libs to use in the filesystem tree 
13 Name:           perl-Find-Lib
14 Version:        1.01
15 Release:        0.1
16 # same as perl
17 License:        GPL v1+ or Artistic
18 Group:          Development/Languages/Perl
19 Source0:        http://www.cpan.org/modules/by-module/Find/%{pdir}-%{pnam}-%{version}.tar.gz
20 # Source0-md5:  8986f9679a88fb265a5e5cf4720f22a1
21 URL:            http://search.cpan.org/dist/Find-Lib/
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 %if %{with autodeps} || %{with tests}
25 # foo
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Helper to smartly find libs to use in the filesystem tree
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} pure_install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{_mandir}/man3/Find::Lib.3pm*
57 %dir %{perl_vendorlib}/Find
58 %{perl_vendorlib}/Find/Lib.pm
This page took 0.098016 seconds and 3 git commands to generate.