]> git.pld-linux.org Git - packages/perl-Finance-Quote.git/blob - perl-Finance-Quote.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Finance-Quote.git] / perl-Finance-Quote.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Finance
6 %define         pnam    Quote
7 Summary:        Finance::Quote - Get stock and mutual fund quotes from various exchanges
8 Summary(pl.UTF-8):      Finance::Quote - Pobieranie notowań giełdowych i funduszy powierniczych
9 Name:           perl-Finance-Quote
10 Version:        1.17
11 Release:        1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Finance/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  446dba3837ffa395bffdea268824e0c1
16 URL:            http://search.cpan.org/dist/Finance-Quote/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(Crypt::SSLeay)
21 BuildRequires:  perl(HTML::TableExtract)
22 BuildRequires:  perl(HTML::TreeBuilder)
23 BuildRequires:  perl-libwww
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module gets stock quotes from various Internet sources, including
30 Yahoo! Finance, Fidelity Investments, and the Australian Stock
31 Exchange. There are two methods of using this module - a functional
32 interface that is depreciated, and an object-orientated method that
33 provides greater flexibility and stability.
34
35 %description -l pl.UTF-8
36 Ten moduł pobiera notowania giełdowe z różnych źródeł w Internecie, w
37 tym z Yahoo! Finance, Fidelity Investments i Australian Stock Exchange
38 (giełdy australijskiej). Istnieją dwie metody użycia tego modułu -
39 przestarzały interfejs funkcyjny i zorientowana obiektowo metoda
40 dająca większą elastyczność i stabilność.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} pure_install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60 cp -a Examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc ChangeLog INSTALL README
68 %dir %{perl_vendorlib}/Finance
69 %{perl_vendorlib}/Finance/*.pm
70 %dir %{perl_vendorlib}/Finance/Quote
71 %{perl_vendorlib}/Finance/Quote/*.pm
72 %dir %{perl_vendorlib}/Finance/Quote/Yahoo
73 %{perl_vendorlib}/Finance/Quote/Yahoo/*.pm
74 %{_mandir}/man3/*
75 %{_examplesdir}/%{name}-%{version}
This page took 0.073007 seconds and 4 git commands to generate.