]> git.pld-linux.org Git - packages/perl-Filter-Template.git/blob - perl-Filter-Template.spec
- tabs in preamble
[packages/perl-Filter-Template.git] / perl-Filter-Template.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Filter
7 %define         pnam    Template
8 Summary:        Filter::Template - source filter for inline code templates
9 Summary(pl.UTF-8):      Filter::Template - filtr kodu źródłowego dla szablonów kodu inline
10 Name:           perl-Filter-Template
11 Version:        1.02
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Filter/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  15aa7b46d94c2dcd9fe0acc8914943df
18 URL:            http://search.cpan.org/dist/Filter-Template/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Filter::Template is a Perl source filter that provides simple inline
26 source code templates. Inlined source code can be significantly faster
27 than subroutines, especially for small-scale functions like accessors
28 and mutators. On the other hand, they are more difficult to maintain
29 and use. Choose your trade-offs wisely.
30
31 %description -l pl.UTF-8
32 Filter::Template to filtr kodu źródłowego Perla udostępniający proste
33 szablony kodu źródłowego inline. Kod źródłowy inline może być znacząco
34 szybszy niż podprocedury, zwłaszcza dla małych funkcji takich jak
35 accessor czy mutator. Z drugiej strony są one dużo trudniejsze w
36 utrzymywaniu i używaniu. Trzeba dokonać mądrego wyboru.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} pure_install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc CHANGES README
61 %{perl_vendorlib}/Filter/Template.pm
62 %dir %{perl_vendorlib}/Filter/Template
63 %{perl_vendorlib}/Filter/Template/UseBytes.pm
64 %{_mandir}/man3/*
This page took 0.078901 seconds and 3 git commands to generate.