]> git.pld-linux.org Git - packages/perl-File-ReadBackwards.git/blob - perl-File-ReadBackwards.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-File-ReadBackwards.git] / perl-File-ReadBackwards.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    File
6 %define         pnam    ReadBackwards
7 Summary:        File::ReadBackwards - read a file backwards by lines
8 Summary(pl.UTF-8):      File::ReadBackwards - czytanie pliku od końca, linia po linii
9 Name:           perl-File-ReadBackwards
10 Version:        1.05
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  613d9d02de6c1d86d5fa5b8816a6b214
17 URL:            http://search.cpan.org/dist/File-ReadBackwards/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 File::ReadBackwards reads a file backwards line by line. It is simple
25 to use, memory efficient and fast. It supports both an object and a
26 tied handle interface.
27
28 %description -l pl.UTF-8
29 File::ReadBackwards czyta plik od końca, linia po linii. Jest prosty w
30 użyciu, wydajny pod względem zajętości pamięci i szybki. Obsługuje
31 zarówno interfejs obiektowy, jak i dowiązane (przez tie()) uchwyty.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %{perl_vendorlib}/File/ReadBackwards.pm
56 %{_mandir}/man3/File::ReadBackwards.3pm*
This page took 0.088842 seconds and 4 git commands to generate.