]> git.pld-linux.org Git - packages/perl-File-Next.git/blob - perl-File-Next.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-File-Next.git] / perl-File-Next.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    File
6 %define pnam    Next
7 Summary:        File::Next - File-finding iterator
8 Name:           perl-File-Next
9 Version:        1.16
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  103bc329cd2b64ec270ac53a7dacb378
16 URL:            http://search.cpan.org/dist/File-Next/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-Test-Pod
21 BuildRequires:  perl-Test-Pod-Coverage
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 File::Next is an iterator-based module for finding files. It's
28 lightweight, has no dependencies, runs under taint mode, and puts your
29 program more directly in control of file selection.
30
31 It's taken heavily from Mark Jason Dominus' excellent book "Higher
32 Order Perl" <http://hop.perl.plover.com/>.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README.md
58 %{perl_vendorlib}/File/Next.pm
59 %{_mandir}/man3/*
This page took 0.075321 seconds and 4 git commands to generate.