]> git.pld-linux.org Git - packages/perl-File-Inplace.git/blob - perl-File-Inplace.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-File-Inplace.git] / perl-File-Inplace.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    File
6 %define         pnam    Inplace
7 Summary:        File::Inplace - Perl module for in-place editing of files
8 Summary(pl.UTF-8):      File::Inplace - moduł Perla do modyfikowania plików w miejscu
9 Name:           perl-File-Inplace
10 Version:        0.20
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  fae0848ebef6969502dde017805a31a1
17 URL:            http://search.cpan.org/dist/File-Inplace/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 File::Inplace is a Perl module intended to ease the common task of
25 editing a file in-place. Inspired by variations of perl's -i option,
26 this module is intended for somewhat more structured and reusable
27 editing than command line perl typically allows. File::Inplace
28 endeavors to guarantee file integrity; that is, either all of the
29 changes made will be saved to the file, or none will. It also offers
30 functionality such as backup creation, automatic field splitting
31 per-line, automatic chomping/unchomping, and aborting edits partially
32 through without affecting the original file.
33
34 %description -l pl.UTF-8
35 File::Inplace to moduł Perla mający na celu ułatwienie modyfikowania
36 plików w miejscu. Jest zainspirowany wariantami opcji -i programu perl
37 i ma udostępniać bardziej strukturalne i nadające się do ponownego
38 zastosowania formy edycji, niż zwykle pozwala wywoływanie perla z
39 linii poleceń. File::Inplace próbuje zagwarantować integralność pliku
40 - co oznacza, że albo wszystkie zmiany zostaną zapisane, albo żadna.
41 Oferuje także funkcje takie jak tworzenie kopii zapasowych,
42 automatyczny podział na pola w linii, automatyczne usuwanie i
43 dodawanie separatorów (chomp/unchomp) oraz przerywanie nie
44 zakończonych modyfikacji bez naruszania oryginalnego pliku.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} pure_install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes README
68 %{perl_vendorlib}/File/Inplace.pm
69 %{_mandir}/man3/File::Inplace.3pm*
This page took 0.098945 seconds and 4 git commands to generate.