]> git.pld-linux.org Git - packages/perl-File-Find-Rule-Perl.git/blob - perl-File-Find-Rule-Perl.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-File-Find-Rule-Perl.git] / perl-File-Find-Rule-Perl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    File
6 %define         pnam    Find-Rule-Perl
7 Summary:        File::Find::Rule::Perl - Common rules for searching for Perl things
8 Summary(pl.UTF-8):      File::Find::Rule::Perl - wspólne reguly do szukania rzeczy perlowych
9 Name:           perl-File-Find-Rule-Perl
10 Version:        1.15
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d8b458792b7eed83c744ae30b1bc3348
17 URL:            http://search.cpan.org/dist/File-Find-Rule-Perl/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(File::Spec) >= 0.82
22 BuildRequires:  perl-File-Find-Rule >= 0.20
23 BuildRequires:  perl-Params-Util >= 0.38
24 BuildRequires:  perl-Parse-CPAN-Meta >= 1.38
25 BuildRequires:  perl-Test-Simple >= 0.47
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 When one writes a lot of things that muck with Perl files, it's often
32 annoying that finding "perl files" requires a moderately complex
33 File::Find::Rule pattern.
34
35 File::Find::Rule::Perl provides methods for finding various types
36 Perl-related files, or replicating search queries run on a
37 distribution in various parts of the CPAN ecosystem.
38
39 %description -l pl.UTF-8
40 Przy pisaniu wielu rzeczy obrabiających pliki perlowe, często staje
41 się uciążliwe to, że wyszukiwanie "plików perlowych" wymaga dość
42 złożonego wzorca File::Find::Rule.
43
44 File::Find::Rule::Perl dostarcza metody do wyszukiwania różnych
45 rodzajów plików związanych z Perlem oraz powtarzalnych zapytań
46 wyszukiwań uruchamianych na dystrybucji w różnych częściach ekosystemu
47 CPAN.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} pure_install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes
71 %{perl_vendorlib}/File/Find/Rule/Perl.pm
72 %{_mandir}/man3/File::Find::Rule::Perl.3pm*
This page took 0.187527 seconds and 4 git commands to generate.