]> git.pld-linux.org Git - packages/perl-File-CounterFile.git/blob - perl-File-CounterFile.spec
use generic url
[packages/perl-File-CounterFile.git] / perl-File-CounterFile.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # do not perform "make test"
4
5 %define         pdir    File
6 %define         pnam    CounterFile
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        File::CounterFile - persistent counter class
9 Summary(pl.UTF-8):      File::CounterFile - klasa trwałych liczników
10 Name:           perl-File-CounterFile
11 Version:        1.04
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  df77e2dbc80aa3ec9647a570bb5e0cf8
18 URL:            http://search.cpan.org/dist/File-CounterFile/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The File::CounterFile Perl module implements a persistent counter
26 class. Each counter is represented by a separate file in the file
27 system. File locking is applied, so multiple processes might try to
28 access the same counters at the same time without risk of counter
29 destruction.
30
31 %description -l pl.UTF-8
32 Moduł Perla File::CounterFile stanowi implementację klasy trwałych
33 liczników. Każdy z liczników jest reprezentowany przez osobny plik w
34 systemie plików. Można stosować są blokady plików, aby z tych samych
35 liczników mogło korzystać jednocześnie wiele procesów, bez ryzyka
36 uszkodzenia licznika.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %{perl_vendorlib}/%{pdir}/%{pnam}.pm
62 %{_mandir}/man3/*
This page took 0.697103 seconds and 4 git commands to generate.