]> git.pld-linux.org Git - packages/perl-File-Cache.git/blob - perl-File-Cache.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-File-Cache.git] / perl-File-Cache.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    File
6 %define         pnam    Cache
7 Summary:        File::Cache - share data between processes via filesystem
8 Summary(pl.UTF-8):      File::Cache - uwspólnianie danych pomiędzy procesami poprzez system plików
9 Name:           perl-File-Cache
10 Version:        0.16
11 Release:        9
12 License:        GPL v1+
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  712371ae4ee88de11072d1616ae0af72
16 URL:            http://search.cpan.org/dist/File-Cache/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 File::Cache implements an object store where data is persisted across
24 processes in the filesystem. It was written to compliment IPC::Cache.
25
26 Where IPC::Cache is faster for small numbers of simple objects,
27 File::Cache tends toward being more performant when caching large
28 numbers of complex objects.
29
30 %description -l pl.UTF-8
31 File::Cache implementuje obiekt przechowujący dane, które są
32 zachowywane na czas działań w systemie plików. Został napisany jako
33 odpowiednik IPC::Cache.
34
35 O ile IPC::Cache jest szybszy dla małych ilości prostych obiektów,
36 File::Cache próbuje być bardziej wydajny przy cachowaniu większych
37 ilości złożonych obiektów.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc README TODO CHANGES
61 %{perl_vendorlib}/File/Cache.pm
This page took 0.093194 seconds and 4 git commands to generate.