]> git.pld-linux.org Git - packages/perl-FCGI.git/blob - perl-FCGI.spec
perl 5.38.0 rebuild
[packages/perl-FCGI.git] / perl-FCGI.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define pdir    FCGI
6 Summary:        FCGI - Fast CGI module
7 Summary(pl.UTF-8):      FCGI - szybki moduł CGI
8 Name:           perl-FCGI
9 Version:        0.82
10 Release:        3
11 License:        BSD-like
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/FCGI/FCGI-%{version}.tar.gz
14 # Source0-md5:  f51a6cb522c0ff25043281532ad0479f
15 Source1:        %{name}-acinclude.m4
16 Patch0:         am.patch
17 URL:            https://metacpan.org/dist/FCGI
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  perl-ExtUtils-MakeMaker
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  rpmbuild(macros) >= 1.745
24 %if %{with tests}
25 BuildRequires:  perl-FCGI-Client >= 0.09
26 BuildRequires:  perl-Test-Simple
27 %endif
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This is a FastCGI module for perl. It's based on the FCGI module that
32 comes with Open Market's FastCGI Developer's Kit, but does not require
33 you to recompile perl.
34
35 %description -l pl.UTF-8
36 To jest moduł FastCGI. Jest bazowany na module FCGI dostarczanym z
37 FastCGI Developer's Kit, ale nie wymaga rekompilacji Perla.
38
39 %prep
40 %setup -q -n %{pdir}-%{version}
41 %patch0 -p1
42 cp -f %{SOURCE1} acinclude.m4
43
44 %build
45 %{__aclocal}
46 %{__autoconf}
47 %configure
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make} \
51         CC="%{__cc}" \
52         OPTIMIZE="%{rpmcflags}"
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 %{__make} pure_install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 install eg/*.pl $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc ChangeLog README
71 %{perl_vendorarch}/FCGI.pm
72 %dir %{perl_vendorarch}/auto/FCGI
73 %attr(755,root,root) %{perl_vendorarch}/auto/FCGI/FCGI.so
74 %{_mandir}/man3/FCGI.3pm*
75 %dir %{_examplesdir}/%{name}-%{version}
76 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
This page took 0.12948 seconds and 4 git commands to generate.