]> git.pld-linux.org Git - packages/perl-ExtUtils-XSpp.git/blob - perl-ExtUtils-XSpp.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-ExtUtils-XSpp.git] / perl-ExtUtils-XSpp.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    ExtUtils
6 %define pnam    XSpp
7 Summary:        ExtUtils::XSpp - XS for C++
8 Summary(pl.UTF-8):      ExtUtils::XSpp - XS dla C++
9 Name:           perl-ExtUtils-XSpp
10 Version:        0.18
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/ExtUtils/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  c44ad3281df81319d02833a4e42282ac
17 URL:            http://search.cpan.org/dist/ExtUtils-XSpp/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Test-Base
22 BuildRequires:  perl-Test-Differences
23 %endif
24 Requires:       perl-Digest-MD5 >= 2.0
25 Requires:       perl-ExtUtils-ParseXS >= 3.07
26 Requires:       perl(ExtUtils::Typemaps) >= 1
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 XS++ is just a thin layer over plain XS.
31
32 %description -l pl.UTF-8
33 XS++ to niewielka warstwa nad zwykłym XS.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Build.PL \
40         config="optimize='%{rpmcflags}'" \
41         destdir=$RPM_BUILD_ROOT \
42         installdirs=vendor
43 ./Build
44
45 %{?with_tests:./Build test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 ./Build install
51
52 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/ExtUtils/XSpp.pod \
56         $RPM_BUILD_ROOT%{perl_vendorlib}/ExtUtils/XSpp/Plugin.pod
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %attr(755,root,root) %{_bindir}/xspp
65 %{perl_vendorlib}/ExtUtils/XSpp.pm
66 %dir %{perl_vendorlib}/ExtUtils/XSpp
67 %{perl_vendorlib}/ExtUtils/XSpp/*.pm
68 %{perl_vendorlib}/ExtUtils/XSpp/Exception
69 %{perl_vendorlib}/ExtUtils/XSpp/Node
70 %dir %{perl_vendorlib}/ExtUtils/XSpp/Plugin
71 %dir %{perl_vendorlib}/ExtUtils/XSpp/Plugin/feature
72 %{perl_vendorlib}/ExtUtils/XSpp/Plugin/feature/default_xs_typemap.pm
73 %{perl_vendorlib}/ExtUtils/XSpp/Typemap
74 %{_mandir}/man1/xspp.1p*
75 %{_mandir}/man3/ExtUtils::XSpp*.3pm*
76 %{_examplesdir}/%{name}-%{version}
This page took 0.104408 seconds and 4 git commands to generate.