]> git.pld-linux.org Git - packages/perl-ExtUtils-MakeMaker-CPANfile.git/commitdiff
new, version 0.06 auto/th/perl-ExtUtils-MakeMaker-CPANfile-0.06-1
authorElan Ruusamäe <glen@delfi.ee>
Mon, 28 Sep 2015 07:48:06 +0000 (10:48 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 28 Sep 2015 07:48:55 +0000 (10:48 +0300)
based on fedora package 08ff7c5

perl-ExtUtils-MakeMaker-CPANfile.spec [new file with mode: 0644]

diff --git a/perl-ExtUtils-MakeMaker-CPANfile.spec b/perl-ExtUtils-MakeMaker-CPANfile.spec
new file mode 100644 (file)
index 0000000..77812cb
--- /dev/null
@@ -0,0 +1,60 @@
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+
+%define                pdir    ExtUtils
+%define                pnam    MakeMaker-CPANfile
+%include       /usr/lib/rpm/macros.perl
+Summary:       CPANfile support for ExtUtils::MakeMaker
+Name:          perl-ExtUtils-MakeMaker-CPANfile
+Version:       0.06
+Release:       1
+License:       GPL+ or Artistic
+Group:         Development/Libraries
+Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 8e1a42d67b57ed15e08e25872dd84cac
+URL:           http://search.cpan.org/dist/ExtUtils-MakeMaker-CPANfile/
+BuildRequires: perl(ExtUtils::MakeMaker) >= 6.17
+BuildRequires: perl(version) >= 0.76
+BuildRequires: perl-Module-CPANfile
+BuildRequires: rpm-perlprov >= 4.1-13
+%if %{with tests}
+BuildRequires: perl(Test::More) >= 0.88
+%endif
+Requires:      perl(ExtUtils::MakeMaker) >= 6.17
+Requires:      perl(version) >= 0.76
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+ExtUtils::MakeMaker::CPANfile loads cpanfile in your distribution and
+modifies parameters for WriteMakefile in your Makefile.PL. Just use it
+instead of ExtUtils::MakeMaker (which should be loaded internally),
+and prepare cpanfile.
+
+%prep
+%setup -q -n %{pdir}-%{pnam}-%{version}
+
+%build
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+%{?with_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__make} pure_install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+find $RPM_BUILD_ROOT -type f -name .packlist | xargs rm
+
+%check
+make test
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc Changes LICENSE README.md
+%{perl_vendorlib}/*
+%{_mandir}/man3/*
This page took 0.073858 seconds and 4 git commands to generate.