]> git.pld-linux.org Git - packages/perl-ExtUtils-Depends.git/blob - perl-ExtUtils-Depends.spec
- noarch, release 2
[packages/perl-ExtUtils-Depends.git] / perl-ExtUtils-Depends.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    ExtUtils
6 %define         pnam    Depends
7 Summary:        ExtUtils::Depends - easily build XS extensions that depend on XS extensions
8 Summary(pl.UTF-8):      ExtUtils::Depends - łatwe budowanie rozszerzeń XS zależących od innych rozszerzeń XS
9 Name:           perl-ExtUtils-Depends
10 Version:        0.8000
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/ExtUtils/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ac2d17114f1b50624a8f37381c90485e
17 URL:            https://metacpan.org/release/ExtUtils-Depends
18 BuildRequires:  perl-devel >= 1:5.8.0
19 %if %{with tests}
20 BuildRequires:  perl-Test-Number-Delta >= 1.0
21 BuildRequires:  perl-Test-Simple
22 %endif
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRequires:  rpmbuild(macros) >= 1.745
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module tries to make it easy to build Perl extensions that use
29 functions and typemaps provided by other Perl extensions.
30
31 %description -l pl.UTF-8
32 Ten moduł próbuje ułatwić budowanie perlowych rozszerzeń używających
33 funkcji i map typów udostępnianych przez inne rozszerzenia Perla.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41
42 %{__make} \
43         CC="%{__cc}" \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes
60 %{perl_vendorlib}/ExtUtils/Depends.pm
61 %{_mandir}/man3/ExtUtils::Depends.3pm*
This page took 0.0757 seconds and 3 git commands to generate.