]> git.pld-linux.org Git - packages/perl-ExtUtils-Depends.git/blob - perl-ExtUtils-Depends.spec
- new style bcond
[packages/perl-ExtUtils-Depends.git] / perl-ExtUtils-Depends.spec
1 #
2 # Conditional build:
3 %bcond_without tests    # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    ExtUtils
7 %define pnam    Depends
8 Summary:        ExtUtils::Depends - Easily build XS extensions
9 Summary(pl):    ExtUtils::Depends - ³atwe budowanie rozszerzeñ XS
10 Name:           perl-%{pdir}-%{pnam}
11 Version:        0.103
12 Release:        0.1
13 License:        GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://dl.sourceforge.net/gtk2-perl/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  aed7a154182cc9bffb020a64f22ae022
17 URL:            http://gtk2-perl.sf.net/
18 BuildRequires:  perl-devel >= 5.8.0
19 BuildRequires:  perl-tools-pod
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module tries to make it easy to build Perl extensions that use
25 functions and typemaps provided by other Perl extensions.
26
27 %description -l pl
28 Ten modu³ próbuje u³atwiæ budowanie perlowych rozszerzeñ u¿ywaj±cych
29 funkcji i map typów udostêpnianych przez inne rozszerzenia Perla.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 %{__perl} Makefile.PL \
36         INSTALLDIRS=vendor
37
38 %{__make} \
39         OPTIMIZE="%{rpmcflags}"
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes README
55 %{perl_vendorlib}/ExtUtils/Depends.pm
56 %{_mandir}/man3/*
This page took 0.088563 seconds and 3 git commands to generate.