]> git.pld-linux.org Git - packages/perl-ExtUtils-CppGuess.git/blob - perl-ExtUtils-CppGuess.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-ExtUtils-CppGuess.git] / perl-ExtUtils-CppGuess.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    ExtUtils
6 %define         pnam    CppGuess
7 Summary:        ExtUtils::CppGuess - guess C++ compiler and flags
8 Name:           perl-ExtUtils-CppGuess
9 Version:        0.09
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/ExtUtils/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  f8ada38ee4ad86a4f1e20d8525ce0c99
16 URL:            http://search.cpan.org/dist/ExtUtils-CppGuess/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-Capture-Tiny
21 %endif
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 ExtUtils::CppGuess attempts to guess the system's C++ compiler
26 that is compatible with the C compiler that your perl was built with.
27
28 It can generate the necessary options to the Module::Build
29 constructor or to ExtUtils::MakeMaker's WriteMakefile
30 function.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make} \
39         CC="%{__cc}" \
40         OPTIMIZE="%{rpmcflags}"
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} pure_install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorlib}/ExtUtils/CppGuess.pm
57 %{_mandir}/man3/*
This page took 0.06428 seconds and 4 git commands to generate.