]> git.pld-linux.org Git - packages/perl-ExtUtils-CChecker.git/blob - perl-ExtUtils-CChecker.spec
c7f1d5fb18b00f0b4b840945b8c8431d71947ea9
[packages/perl-ExtUtils-CChecker.git] / perl-ExtUtils-CChecker.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    ExtUtils
7 %define pnam    CChecker
8 Summary:        ExtUtils::CChecker - configure-time utilities for using C headers, libraries, or OS features
9 #Summary(pl.UTF-8):
10 Name:           perl-ExtUtils-CChecker
11 Version:        0.03
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/ExtUtils-CChecker-%{version}.tar.gz
17 # Source0-md5:  f2a9da32e70ec32c5b47652e020021d0
18 URL:            http://search.cpan.org/dist/ExtUtils-CChecker/
19 BuildRequires:  perl-Module-Build
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-Test-Exception
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Often Perl modules are written to wrap functionallity found in
30 existing C headers, libraries, or to use OS-specific features. It is
31 useful in the Build.PL or Makefile.PL file to check for the existance
32 of these requirements before attempting to actually build the module.
33
34 Objects in this class provide an extension around ExtUtils::CBuilder
35 to simplify the creation of a .c file, compiling, linking and running
36 it, to test if a certain feature is present.
37
38 It may also be necessary to search for the correct library to link
39 against, or for the right include directories to find header files in.
40 This class also provides assistance here.
41
42 # %description -l pl.UTF-8
43 # TODO
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Build.PL \
50         destdir=$RPM_BUILD_ROOT \
51         installdirs=vendor
52 ./Build
53
54 %{?with_tests:./Build test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 ./Build install
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %{perl_vendorlib}/ExtUtils/*.pm
68 %{_mandir}/man3/*
This page took 0.082717 seconds and 3 git commands to generate.