]> git.pld-linux.org Git - packages/perl-Exporter-Easy.git/commitdiff
- new
authorradek <radek@pld-linux.org>
Sun, 2 Mar 2003 13:42:03 +0000 (13:42 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    perl-Exporter-Easy.spec -> 1.1

perl-Exporter-Easy.spec [new file with mode: 0644]

diff --git a/perl-Exporter-Easy.spec b/perl-Exporter-Easy.spec
new file mode 100644 (file)
index 0000000..3c65e8b
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Conditional build:
+# _without_tests - do not perform "make test"
+#
+%include       /usr/lib/rpm/macros.perl
+%define        pdir    Exporter
+%define        pnam    Easy
+Summary:       Exporter::Easy - Takes the drudgery out of Exporting symbols
+#Summary(pl):  
+Name:          perl-Exporter-Easy
+Version:       0.15
+Release:       1
+License:       ?
+Group:         Development/Languages/Perl
+Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+BuildRequires: perl >= 5.6
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Eporter::Easy gets rid of the drudgery of exporting symbols allowing you
+to eliminate those bits of code that exists in every single module that
+uses Exporter.
+
+It also allows you to define tags in terms of other tags  and you no
+longer have to worry about filling in @EXPORT_OK.
+
+# %description -l pl
+# TODO
+
+%prep
+%setup -q -n %{pdir}-%{pnam}-%{version}
+
+%build
+%{__perl} -pi -e "s/INSTALLDIRS => 'perl',//" Makefile.PL
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor 
+%{__make}
+
+%{!?_without_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README CHANGES
+%{perl_vendorlib}/%{pdir}/*.pm
+%{_mandir}/man3/*
This page took 0.046235 seconds and 4 git commands to generate.