]> git.pld-linux.org Git - packages/perl-Email-Sender.git/blob - perl-Email-Sender.spec
- updated to 2.601
[packages/perl-Email-Sender.git] / perl-Email-Sender.spec
1 # TODO:
2 #       - Obsolete perl-Email-Send?
3 #
4 # Conditional build:
5 %bcond_without  tests           # do not perform "make test"
6
7 %define         pdir    Email
8 %define         pnam    Sender
9 Summary:        Email::Sender - a library for sending email
10 Name:           perl-Email-Sender
11 Version:        2.601
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Email/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  20aed58073155ac38530b3d64eb73379
18 URL:            https://github.com/rjbs/Email-Sender
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(Capture::Tiny) >= 0.08
23 BuildRequires:  perl(Email::Abstract) >= 3.006
24 BuildRequires:  perl(Email::Simple) >= 1.998
25 BuildRequires:  perl(Moo) >= 1.000008
26 BuildRequires:  perl(MooX::Types::MooseLike) >= 0.15
27 BuildRequires:  perl(MooX::Types::MooseLike::Base)
28 BuildRequires:  perl(Throwable::Error) >= 0.200003
29 BuildRequires:  perl-Class-Method-Modifiers
30 BuildRequires:  perl-Email-Address
31 BuildRequires:  perl-List-MoreUtils
32 BuildRequires:  perl-Module-Runtime
33 BuildRequires:  perl-Moo
34 BuildRequires:  perl-Sub-Exporter
35 BuildRequires:  perl-Try-Tiny
36 %endif
37 Requires:       perl-Throwable
38 BuildArch:      noarch
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Email::Sender replaces the old and sometimes problematic Email::Send
43 library, which did a decent job at handling very simple email sending
44 tasks, but was not suitable for serious use, for a variety of reasons.
45
46 Most users will be able to use Email::Sender::Simple to send mail.
47 Users with more specific needs should look at the available
48 Email::Sender::Transport classes.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52
53 %build
54 %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56 %{__make}
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 %{__make} pure_install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README
71 %{perl_vendorlib}/Email/*.pm
72 %{perl_vendorlib}/Email/Sender
73 %{_mandir}/man3/*
This page took 0.842629 seconds and 4 git commands to generate.