]> git.pld-linux.org Git - packages/perl-Email-Address.git/blob - perl-Email-Address.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Email-Address.git] / perl-Email-Address.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Email
6 %define         pnam    Address
7 Summary:        Email::Address - RFC 2822 Address Parsing and Creation
8 Summary(pl.UTF-8):      Email::Address - analiza i tworzenie adresów zgodnych z RFC 2822
9 Name:           perl-Email-Address
10 Version:        1.912
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Email/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  24a75497f11e8a8225cb6d99a5e6e647
17 URL:            http://search.cpan.org/dist/Email-Address/
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.30
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Capture-Tiny
23 BuildRequires:  perl-Encode
24 BuildRequires:  perl-Test-Simple >= 0.96
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This class implements a complete RFC 2822 parser that locates email
31 addresses in strings and returns a list of Email::Address objects
32 found. Alternatley you may construct objects manually. The goal of
33 this software is to be correct, very very fast, and API compatible
34 with the MailTools version. Did I mention fast?
35
36 %description -l pl.UTF-8
37 Ta klasa implementuje zgodny z RFC 2822 parser odnajdujący adresy
38 email w ciągach znaków i zwraca listę obiektów Email::Address. Możliwe
39 jest także tworzenie takich obiektów ręczenie. Oprogramowanie to ma
40 być poprawne, bardzo, bardzo szybkie, i z API zgodnym z MailTools.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %{perl_vendorlib}/Email/Address.pm
66 %{_mandir}/man3/Email::Address.3pm*
This page took 0.0911689999999999 seconds and 4 git commands to generate.