]> git.pld-linux.org Git - packages/perl-Dist-CheckConflicts.git/blob - perl-Dist-CheckConflicts.spec
- macros for perl autodeps
[packages/perl-Dist-CheckConflicts.git] / perl-Dist-CheckConflicts.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Dist
6 %define         pnam    CheckConflicts
7 Summary:        Dist::CheckConflicts - declare version conflicts for your dist
8 Summary(pl.UTF-8):      Dist::CheckConflicts - deklarowanie wersji będących w konflikcie z pakietem
9 Name:           perl-Dist-CheckConflicts
10 Version:        0.11
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Dist/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  c8725a92b9169708b0f63036812070f2
17 URL:            https://metacpan.org/release/Dist-CheckConflicts
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.30
19 BuildRequires:  perl-devel >= 1:5.8.1
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-Module-Runtime >= 0.009
24 BuildRequires:  perl-Test-Fatal
25 BuildRequires:  perl-Test-Simple >= 0.88
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 One shortcoming of the CPAN clients that currently exist is that they
32 have no way of specifying conflicting downstream dependencies of
33 modules. This module attempts to work around this issue by allowing
34 you to specify conflicting versions of modules separately, and deal
35 with them after the module is done installing.
36
37 For instance, say you have a module Foo, and some other module Bar
38 uses Foo. If Foo were to change its API in a non-backwards-compatible
39 way, this would cause Bar to break until it is updated to use the new
40 API. Foo can't just depend on the fixed version of Bar, because this
41 will cause a circular dependency (because Bar is already depending on
42 Foo), and this doesn't express intent properly anyway - Foo doesn't
43 use Bar at all. The ideal solution would be for there to be a way to
44 specify conflicting versions of modules in a way that would let CPAN
45 clients update conflicting modules automatically after an existing
46 module is upgraded, but until that happens, this module will allow
47 users to do this manually.
48
49 %description -l pl.UTF-8
50 Jednym z obecnych niedociągnięć klientów CPAN jest to, że nie ma
51 sposobu określenia zależności będących w konflikcie z modułami.
52 Niniejszy moduł próbuje obejść ten problem pozwalając określić
53 osobno wersje modułów będących w konflikcie i obsłużenie ich po
54 zainstalowaniu modułu.
55
56 Na przykład: mamy moduł Foo, a inny moduł Bar używa Foo. Jeśli Foo
57 zmieni swoje API bez kompatybilności wstecznej, spowoduje to zepsucie
58 Bar do jego uaktualnienia pod kątem nowego API. Foo nie może
59 zwyczajnie zależeć od poprawionej wersji Bar, bo spowodowałoby to
60 zależność cykliczną (ponieważ Bar już zależy od Foo) i nie wyraża
61 właściwie intencji - Foo w ogóle nie używa Bar. Idealnym rozwiązaniem
62 byłoby zapewnienie sposobu określania wersji modułów będących w
63 konflikcie w sposób pozwalający klientom CPAN na automatyczne
64 uaktualnienie będących w konflikcie modułów po uaktualnieniu
65 istniejącego modułu - ale zanim to nastąpi, ten moduł pozwala
66 użytkownikom uczynić to ręcznie.
67
68 %prep
69 %setup -q -n %{pdir}-%{pnam}-%{version}
70
71 %build
72 %{__perl} Makefile.PL \
73         INSTALLDIRS=vendor
74 %{__make}
75
76 %{?with_tests:%{__make} test}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %{__make} pure_install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc Changes README
90 %dir %{perl_vendorlib}/Dist
91 %{perl_vendorlib}/Dist/CheckConflicts.pm
92 %{_mandir}/man3/Dist::CheckConflicts.3pm*
This page took 0.075032 seconds and 4 git commands to generate.