]> git.pld-linux.org Git - packages/perl-Devel-Symdump.git/blob - perl-Devel-Symdump.spec
- macros for perl autodeps
[packages/perl-Devel-Symdump.git] / perl-Devel-Symdump.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Devel
6 %define         pnam    Symdump
7 Summary:        Devel::Symdump - dump symbol names or the symbol table
8 Summary(pl.UTF-8):      Devel::Symdump - zrzucanie nazw symboli lub tablicy symboli
9 Name:           perl-Devel-Symdump
10 Version:        2.18
11 Release:        1
12 Epoch:          1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Devel/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  3dd7e1c7779a37c31a3eb60c0a97ea9f
18 URL:            https://metacpan.org/release/Devel-Symdump
19 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.45_02
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  rpmbuild(macros) >= 1.745
23 %if %{with tests}
24 BuildRequires:  perl-Compress-Zlib
25 BuildRequires:  perl-Test-Pod-Coverage
26 BuildRequires:  perl-Test-Simple
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This little package serves to access the symbol table of perl. It
33 dumps symbol names or the symbol table.
34
35 %description -l pl.UTF-8
36 Ten niewielki pakiet służy do dostępu do tablicy symboli Perla.
37 Pobiera on nazwy symboli lub tablicę symboli.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes
61 %{perl_vendorlib}/Devel/Symdump.pm
62 %{perl_vendorlib}/Devel/Symdump
63 %{_mandir}/man3/Devel::Symdump.3pm*
This page took 0.122239 seconds and 4 git commands to generate.