]> git.pld-linux.org Git - packages/perl-Devel-PPPort.git/blob - perl-Devel-PPPort.spec
- rel 2
[packages/perl-Devel-PPPort.git] / perl-Devel-PPPort.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Devel
7 %define pnam    PPPort
8 Summary:        Devel::PPPort - Perl/Pollution/Portability
9 Summary(pl.UTF-8):      Devel:::PPPort - Perl/Zanieczyszczenie/Przenośność
10 Name:           perl-Devel-PPPort
11 Version:        3.11_01
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/M/MH/MHX/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  d446bc2e6346d213dffa67d6d3ac2965
18 URL:            http://search.cpan.org/dist/Devel-PPPort/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Perl's API has changed over time, gaining new features, new functions,
25 increasing its flexibility, and reducing the impact on the C namespace
26 environment (reduced pollution). The header file written by this module,
27 typically ppport.h, attempts to bring some of the newer Perl API
28 features to older versions of Perl, so that you can worry less about
29 keeping track of old releases, but users can still reap the benefit.
30
31 Devel::PPPort contains a single function, called WriteFile. Its
32 only purpose is to write the ppport.h C header file. This file
33 contains a series of macros and, if explicitly requested, functions that
34 allow XS modules to be built using older versions of Perl. Currently,
35 Perl versions from 5.003 to 5.9.4 are supported.
36
37 This module is used by h2xs to write the file ppport.h.
38
39 %description -l pl.UTF-8
40 Perlowe API zmieniało się w czasie, zyskując nowe możliwości, nowe
41 funkcje, zwiększając elastyczność i zmniejszając wpływ na środowisko
42 przestrzeni nazw C (mniejsze zanieczyszczenie). Plik nagłówkowy
43 zapisywany przez ten moduł, zwykle ppport.h, próbuje udostępnić
44 niektóre z nowych możliwości API Perla w starszych wersjach Perla, aby
45 mniej trzeba było martwić się o śledzenie starszych wersji.
46
47 Devel::PPPort zawiera jedną funkcję - WriteFile. Jej jedynym celem
48 jest zapis pliku nagłówkowego C ppport.h. Plik ten zawiera ciąg makr
49 i, jeśli tego zażądano, funkcje pozwalające na budowanie modułów XS
50 przy użyciu starszych wersji Perla. Aktualnie obsługiwane są wersje
51 Perla od 5.003 do 5.9.4.
52
53 Ten moduł jest używany przez h2xs do zapisu pliku ppport.h.
54
55 %prep
56 %setup -q -n %{pdir}-%{pnam}-%{version}
57
58 %build
59 %{__perl} Makefile.PL \
60         INSTALLDIRS=vendor
61 %{__make} \
62         CC="%{__cc}" \
63         OPTIMIZE="%{rpmcflags}"
64
65 %{?with_tests:%{__make} test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc Changes README TODO
79 %{perl_vendorarch}/Devel/*.pm
80 %dir %{perl_vendorarch}/auto/Devel/PPPort
81 %{perl_vendorarch}/auto/Devel/PPPort/*.bs
82 %attr(755,root,root) %{perl_vendorarch}/auto/Devel/PPPort/*.so
83 %{_mandir}/man3/*
This page took 0.10615 seconds and 4 git commands to generate.