]> git.pld-linux.org Git - packages/perl-Devel-PPPort.git/blob - perl-Devel-PPPort.spec
- cleanup
[packages/perl-Devel-PPPort.git] / perl-Devel-PPPort.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Devel
7 %define pnam    PPPort
8 Summary:        Devel::PPPort - Perl/Pollution/Portability
9 Summary(pl.UTF-8):      Devel:::PPPort - Perl/Zanieczyszczenie/Przenośność
10 Name:           perl-Devel-PPPort
11 Version:        3.20
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Devel/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  491ff215ff03dffb84902f6b4bb78ada
18 URL:            http://search.cpan.org/dist/Devel-PPPort/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Perl's API has changed over time, gaining new features, new functions,
25 increasing its flexibility, and reducing the impact on the C namespace
26 environment (reduced pollution). The header file written by this
27 module, typically ppport.h, attempts to bring some of the newer Perl
28 API features to older versions of Perl, so that you can worry less
29 about keeping track of old releases, but users can still reap the
30 benefit.
31
32 Devel::PPPort contains a single function, called WriteFile. Its
33 only purpose is to write the ppport.h C header file. This file
34 contains a series of macros and, if explicitly requested, functions
35 that allow XS modules to be built using older versions of Perl.
36 Currently, Perl versions from 5.003 to 5.10.0 are supported.
37
38 This module is used by h2xs to write the file ppport.h.
39
40 %description -l pl.UTF-8
41 Perlowe API zmieniało się w czasie, zyskując nowe możliwości, nowe
42 funkcje, zwiększając elastyczność i zmniejszając wpływ na środowisko
43 przestrzeni nazw C (mniejsze zanieczyszczenie). Plik nagłówkowy
44 zapisywany przez ten moduł, zwykle ppport.h, próbuje udostępnić
45 niektóre z nowych możliwości API Perla w starszych wersjach Perla, aby
46 mniej trzeba było martwić się o śledzenie starszych wersji.
47
48 Devel::PPPort zawiera jedną funkcję - WriteFile. Jej jedynym celem
49 jest zapis pliku nagłówkowego C ppport.h. Plik ten zawiera ciąg makr
50 i, jeśli tego zażądano, funkcje pozwalające na budowanie modułów XS
51 przy użyciu starszych wersji Perla. Aktualnie obsługiwane są wersje
52 Perla od 5.003 do 5.10.0.
53
54 Ten moduł jest używany przez h2xs do zapisu pliku ppport.h.
55
56 %prep
57 %setup -q -n %{pdir}-%{pnam}-%{version}
58
59 %build
60 %{__perl} Makefile.PL \
61         INSTALLDIRS=vendor
62 %{__make} \
63         CC="%{__cc}" \
64         OPTIMIZE="%{rpmcflags}"
65
66 %{?with_tests:%{__make} test}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc Changes README TODO
80 %{perl_vendorarch}/Devel/PPPort.pm
81 %dir %{perl_vendorarch}/auto/Devel/PPPort
82 %{perl_vendorarch}/auto/Devel/PPPort/PPPort.bs
83 %attr(755,root,root) %{perl_vendorarch}/auto/Devel/PPPort/PPPort.so
84 %{_mandir}/man3/Devel::PPPort.3pm*
This page took 0.044761 seconds and 4 git commands to generate.