]> git.pld-linux.org Git - packages/perl-Declare-Constraints-Simple.git/blob - perl-Declare-Constraints-Simple.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Declare-Constraints-Simple.git] / perl-Declare-Constraints-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Declare
6 %define pnam    Constraints-Simple
7 Summary:        Declare::Constraints::Simple - Declarative Validation of Data Structures
8 Summary(pl.UTF-8):      Declare::Constraints::Simple - deklaratywne sprawdzanie poprawności struktur danych
9 Name:           perl-Declare-Constraints-Simple
10 Version:        0.03
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/P/PH/PHAYLON/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  abcd5e9f2dd034deed975601b38d684e
17 URL:            http://search.cpan.org/dist/Declare-Constraints-Simple/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Carp-Clan
22 BuildRequires:  perl-Class-Inspector
23 BuildRequires:  perl-aliased
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _noautoreq      perl(Declare::Constraints::Simple-Library)
29
30 %description
31 The main purpose of this module is to provide an easy way to build a
32 profile to validate a data structure. It does this by giving you a set
33 of declarative keywords in the importing namespace.
34
35 %description -l pl.UTF-8
36 Głównym celem tego modułu jest dostarczenie prostego sposobu budowania
37 profili służących do sprawdzania poprawności sktruktur danych.
38 Zapewnia to udostępniając zbiór deklaratywnych słów kluczowych w
39 importowanej przestrzeni nazw.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} pure_install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %dir %{perl_vendorlib}/Declare
64 %dir %{perl_vendorlib}/Declare/Constraints
65 %{perl_vendorlib}/Declare/Constraints/Simple.pm
66 %{perl_vendorlib}/Declare/Constraints/Simple
67 %{_mandir}/man3/Declare::Constraints::Simple*.3pm*
This page took 0.102367 seconds and 4 git commands to generate.