]> git.pld-linux.org Git - packages/perl-DateTime-Format-Builder.git/blob - perl-DateTime-Format-Builder.spec
- up to 0.7901
[packages/perl-DateTime-Format-Builder.git] / perl-DateTime-Format-Builder.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    DateTime
7 %define pnam    Format-Builder
8 Summary:        DateTime::Format::Builder - Create DateTime parser classes and objects
9 Summary(pl.UTF-8):      DateTime::Format::Builder - tworzenie klas i obiektów analizatorów DateTime
10 Name:           perl-DateTime-Format-Builder
11 Version:        0.7901
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/D/DR/DROLSKY/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  43407285237cdc3cdd2c08b936229198
18 URL:            http://search.cpan.org/dist/DateTime-Format-Builder/
19 BuildRequires:  perl-Module-Build
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-Class-Factory-Util >= 1.6
24 BuildRequires:  perl-DateTime >= 0.12
25 BuildRequires:  perl-DateTime-Format-Strptime >= 1.04
26 BuildRequires:  perl-Params-Validate >= 0.72
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 DateTime::Format::Builder creates DateTime parsers. Many string
33 formats of dates and times are simple and just require a basic
34 regular expression to extract the relevant information. Builder
35 provides a simple way to do this without writing reams of structural
36 code.
37
38 Builder provides a number of methods, most of which you'll never need,
39 or at least rarely need. They're provided more for exposing of the
40 module's innards to any subclasses, or for when you need to do
41 something slightly beyond what I expected.
42
43 %description -l pl.UTF-8
44 DateTime::Format::Builder tworzy analizatory DateTime. Wiele formatów
45 łańcuchów dat i czasu jest prostych i do wyciągnięcia istotnych
46 informacji wymaga jedynie prostego wyrażenia regularnego. Builder
47 udostępnia prosty sposób wykonania tego bez pisania większego kodu
48 strukturalnego.
49
50 Builder udostępnia wiele metod, z których większości się nie używa lub
51 używa bardzo rzadko. Są udostępnione bardziej dla ukazania wnętrzności
52 modułu dla podklas albo w razie potrzeby zrobienia czegoś więcej niż
53 oczekiwał autor.
54
55 %prep
56 %setup -q -n %{pdir}-%{pnam}-%{version}
57
58 %build
59 %{__perl} Build.PL \
60         destdir=$RPM_BUILD_ROOT \
61         installdirs=vendor
62 ./Build
63
64 %{?with_tests:./Build test}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 ./Build install
70
71 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
72 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc AUTHORS Changes CREDITS INSTALL README
80 %{perl_vendorlib}/DateTime/Format/*.pm
81 %{perl_vendorlib}/DateTime/Format/Builder
82 %{_mandir}/man3/*
83 %{_examplesdir}/%{name}-%{version}
This page took 0.058126 seconds and 3 git commands to generate.