]> git.pld-linux.org Git - packages/perl-Data-Uniqid.git/blob - perl-Data-Uniqid.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Data-Uniqid.git] / perl-Data-Uniqid.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Data
6 %define         pnam    Uniqid
7 Summary:        Data::Uniqid - Perl extension for simple genrating of unique id's
8 Name:           perl-Data-Uniqid
9 Version:        0.12
10 Release:        2
11 License:        GPL v1+ or Artistic
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/Data/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  6bab3b5da09fedfdf60ce2629a7367db
15 URL:            https://metacpan.org/release/Data-Uniqid/
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 %if %{with tests}
19 %endif
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Data::Uniqid provides three simple routines for generating unique ids.
25 These ids are coded with a Base62 systen to make them short and handy
26 (e.g. to use it as part of a URL).
27
28 suinqid genrates a very short id valid only for the localhost and with
29 a liftime of 1 day
30
31 uniqid generates a short id valid on the local host
32
33 luniqid generates a long id valid everywhere and ever
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} pure_install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorlib}/Data/Uniqid.pm
58 %dir %{perl_vendorlib}/auto/Data/Uniqid
59 %{perl_vendorlib}/auto/Data/Uniqid/autosplit.ix
60 %{_mandir}/man3/Data::Uniqid.3*
This page took 0.126974 seconds and 3 git commands to generate.