]> git.pld-linux.org Git - packages/perl-Data-Uniqid.git/blob - perl-Data-Uniqid.spec
- rel 2; ix file is needed
[packages/perl-Data-Uniqid.git] / perl-Data-Uniqid.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Data
6 %define         pnam    Uniqid
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Data::Uniqid - Perl extension for simple genrating of unique id's
9 Name:           perl-Data-Uniqid
10 Version:        0.12
11 Release:        2
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Data/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  6bab3b5da09fedfdf60ce2629a7367db
16 URL:            https://metacpan.org/release/Data-Uniqid/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 %endif
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Data::Uniqid provides three simple routines for generating unique ids.
26 These ids are coded with a Base62 systen to make them short and handy
27 (e.g. to use it as part of a URL).
28
29 suinqid genrates a very short id valid only for the localhost and with
30 a liftime of 1 day
31
32 uniqid generates a short id valid on the local host
33
34 luniqid generates a long id valid everywhere and ever
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorlib}/Data/Uniqid.pm
59 %dir %{perl_vendorlib}/auto/Data/Uniqid
60 %{perl_vendorlib}/auto/Data/Uniqid/autosplit.ix
61 %{_mandir}/man3/Data::Uniqid.3*
This page took 0.22877 seconds and 3 git commands to generate.