]> git.pld-linux.org Git - packages/perl-Data-Table.git/blob - perl-Data-Table.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Data-Table.git] / perl-Data-Table.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Data
6 %define         pnam    Table
7 Summary:        Data::Table - data type related to database tables, spreadsheets, etc
8 Summary(pl.UTF-8):      Data::Table - typ danych dotyczący tabel bazodanowych, arkuszy kalkulacyjnych itp.
9 Name:           perl-Data-Table
10 Version:        1.59
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  058d54d385938afdd7ccd5c09fbb76c9
17 URL:            http://www.geocities.com/easydatabase/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This perl package uses perl5 objects to make it easy for manipulating
25 spreadsheet data among disk files, database, and Web publishing.
26
27 A table object contains a header and a two-dimensional array of
28 scalars. Three class methods allow users to create a table object from
29 a CSV/TSV file or a database SQL selection in a snap.
30
31 Table methods provide basic access, add, delete row(s) or column(s)
32 operations, as well as more advanced sub-table extraction, table
33 sorting, record matching via keywords or patterns, table merging, and
34 web publishing.
35
36 %description -l pl.UTF-8
37 Ten pakiet perlowy używa obiektów Perla 5, aby ułatwić manipulowanie
38 danymi arkuszy kalkulacyjnych w plikach na dysku, bazach danych i
39 publikacjach WWW.
40
41 Obiekt tabeli zawiera nagłówek i dwuwymiarową tablicę skalarów. Trzy
42 metody klasy pozwalają użytkownikom tworzyć obiekt tabeli z pliku
43 CSV/TSV lub wyniku zapytania z bazy danych SQL.
44
45 Metody tabeli umożliwiają podstawowe operacje dostępu, dodawania i
46 usuwania wierszy i kolumn, nieco bardziej zaawansowane wyciąganie
47 podtabel, sortowanie tabel, dopasowywanie rekordów po słowach
48 kluczowych lub wzorcach, łączenie tabel oraz publikowanie na WWW.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52
53 %build
54 %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56 %{__make}
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 # empty autosplit.ix
67 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/auto/Data/Table/autosplit.ix
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %{perl_vendorlib}/Data/*.pm
75 %{_mandir}/man3/*
This page took 0.098411 seconds and 4 git commands to generate.