]> git.pld-linux.org Git - packages/perl-Data-Perl.git/blob - perl-Data-Perl.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Data-Perl.git] / perl-Data-Perl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Data
6 %define         pnam    Perl
7 Summary:        Data::Perl - Base classes wrapping fundamental Perl data types.
8 Name:           perl-Data-Perl
9 Version:        0.002009
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Data/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  2c38f8d7b50a986602a93b93a3cfe40f
16 URL:            http://search.cpan.org/dist/Data-Perl/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-Class-Method-Modifiers
21 BuildRequires:  perl-List-MoreUtils
22 BuildRequires:  perl-Module-Runtime
23 BuildRequires:  perl-Role-Tiny
24 BuildRequires:  perl-strictures
25 BuildRequires:  perl-Test-Deep
26 BuildRequires:  perl-Test-Fatal
27 BuildRequires:  perl-Test-Output
28 %endif
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Data::Perl is a collection of classes that wrap fundamental data types that
34 exist in Perl. These classes and methods as they exist today are an attempt to
35 mirror functionality provided by Moose's Native Traits. One important thing to
36 note is all classes currently do no validation on constructor input.
37
38 Data::Perl is a container class for the following classes:
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorlib}/Data/*.pm
63 %{perl_vendorlib}/Data/Perl
64 %{_mandir}/man3/*
This page took 0.570481 seconds and 4 git commands to generate.