]> git.pld-linux.org Git - packages/perl-Data-Compare.git/blob - perl-Data-Compare.spec
b82e677ca03f77482fc90bbabb18220bef82863e
[packages/perl-Data-Compare.git] / perl-Data-Compare.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Data
7 %define pnam    Compare
8 Summary:        Data::Compare perl module
9 Summary(pl):    Modu³ perla Data::Compare
10 Name:           perl-Data-Compare
11 Version:        0.1
12 Release:        1
13 # same as Perl
14 License:        GPL or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  e5767db3c11416ab474b87b8b50bf841
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  perl-devel >= 5.8
20 %if %{with tests}
21 BuildRequires:  perl-File-Find-Rule >= 0.11
22 BuildRequires:  perl-Scalar-Properties
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Data::Compare perl module - compare perl data structures.
29
30 %description -l pl
31 Modu³ perla Data::Compare s³u¿y do porównywania struktur danych.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make}
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %{perl_vendorlib}/Data/Compare.pm
54 %{perl_vendorlib}/Data/Compare/Plugins
55 %{_mandir}/man3/*
This page took 0.067667 seconds and 3 git commands to generate.