]> git.pld-linux.org Git - packages/perl-DB_File.git/blob - perl-DB_File.spec
perl 5.38.0 rebuild
[packages/perl-DB_File.git] / perl-DB_File.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define db_ver  %(rpm -q --whatprovides --qf '%%|E?{%%{E}:}|%%{V}' db-devel)
6 #
7 %define         pdir    DB_File
8 %define         pnam    DB_File
9 Summary:        DB_File allows to manage a simple ASCII database
10 Summary(pl.UTF-8):      DB_File pozwala na korzystanie z prostej, tekstowej bazy danych
11 Name:           perl-DB_File
12 Version:        1.852
13 Release:        6
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        https://www.cpan.org/authors/id/P/PM/PMQS/DB_File-%{version}.tar.gz
18 # Source0-md5:  7b5aa99abd24ac0813a8c32b58216806
19 Patch0:         %{name}-rpm-automation.patch
20 URL:            http://search.cpan.org/dist/DB_File/
21 BuildRequires:  db-devel
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 Requires:       db = %{db_ver}
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 DB_File is a module which allows Perl programs to make use of the
29 facilities provided by Berkeley DB version 1.
30
31 %description -l pl.UTF-8
32 DB_File jest modułem, który pozwala programom w Perlu na korzystanie
33 z udogodnień dostarczanych przez Berkeley DB w wersji 1.
34
35 %prep
36 %setup -q -n %{pnam}-%{version}
37 %patch0 -p1
38
39 %build
40 %{__perl} -pi -e "s/INSTALLDIRS => 'perl',//" Makefile.PL
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %{perl_vendorarch}/DB_File.pm
62 %dir %{perl_vendorarch}/auto/DB_File
63 %attr(755,root,root) %{perl_vendorarch}/auto/DB_File/DB_File.so
64 %{_mandir}/man3/DB_File.3pm*
This page took 0.199169 seconds and 4 git commands to generate.