]> git.pld-linux.org Git - packages/perl-DBIx-Class.git/blame - perl-DBIx-Class.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-DBIx-Class.git] / perl-DBIx-Class.spec
CommitLineData
28e72b45 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
28e72b45 5%define pdir DBIx
6%define pnam Class
7Summary: DBIx::Class - Extensible and flexible object <-> relational mapper
b40db49d 8Summary(pl.UTF-8): DBIx::Class - rozszerzalne i elastyczne wiązanie obiektów <-> relacji
28e72b45 9Name: perl-DBIx-Class
f2ac0ba4 10Version: 0.08250
31cbaf6a 11Release: 1
28e72b45 12License: GPL v1+ or Artistic
13Group: Development/Languages/Perl
2de26f35 14Source0: http://www.cpan.org/modules/by-module/DBIx/%{pdir}-%{pnam}-%{version}.tar.gz
f2ac0ba4
JR
15# Source0-md5: 4f65022a3d9480f3bb0610580dfdaf56
16Patch0: test.patch
2de26f35 17URL: http://search.cpan.org/dist/DBIx-Class/
28e72b45 18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
c33ed24a 21BuildRequires: perl-Carp-Clan >= 6.0
f2ac0ba4 22BuildRequires: perl-Class-Accessor-Grouped >= 0.10010
31cbaf6a 23BuildRequires: perl-Class-C3-Componentised >= 1.0009
c33ed24a 24BuildRequires: perl-Class-Inspector >= 1.24
f2ac0ba4
JR
25BuildRequires: perl-Context-Preserve
26BuildRequires: perl-Config-Any >= 0.20
31cbaf6a 27BuildRequires: perl-DBD-SQLite >= 1.29
c33ed24a 28BuildRequires: perl-DBI >= 1.605
f2ac0ba4
JR
29BuildRequires: perl-Data-Compare >= 1.22
30BuildRequires: perl-Data-Dumper-Concise >= 2.020
d28fa658 31BuildRequires: perl-Data-Page >= 2.00
31cbaf6a 32BuildRequires: perl-Devel-Cycle >= 1.10
f2ac0ba4 33BuildRequires: perl-Devel-GlobalDestruction
c33ed24a 34BuildRequires: perl-ExtUtils-MakeMaker >= 6.42
35BuildRequires: perl-File-Temp >= 0.22
36BuildRequires: perl-JSON-Any >= 1.18
37BuildRequires: perl-MRO-Compat >= 0.09
38BuildRequires: perl-Module-Find >= 0.06
f2ac0ba4 39BuildRequires: perl-Moo >= 1.004002
c33ed24a 40BuildRequires: perl-Path-Class >= 0.16
f2ac0ba4 41BuildRequires: perl-SQL-Abstract >= 1.73
c33ed24a 42BuildRequires: perl-SQL-Abstract-Limit >= 0.13
f2ac0ba4 43BuildRequires: perl-SQL-Translator >= 0.11006
209a3938 44BuildRequires: perl-Scope-Guard >= 0.03
c33ed24a 45BuildRequires: perl-Sub-Name >= 0.04
46BuildRequires: perl-Test-Deep
31cbaf6a 47BuildRequires: perl-Test-Exception >= 0.31
48BuildRequires: perl-Test-Memory-Cycle
c33ed24a 49BuildRequires: perl-Test-Simple >= 0.92
50BuildRequires: perl-Test-Warn >= 0.21
31cbaf6a 51BuildRequires: perl-Text-CSV
f2ac0ba4 52BuildRequires: perl-namespace-clean
28e72b45 53%endif
54BuildArch: noarch
55BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
bb417167 57# Only APR::UUID is available in PLD. And if it was we would still
68c9fde7 58# need only one of Data::UUID, Data::Uniqid, APR::UUID or UUID at any
59# time to get full functionality
f2ac0ba4 60%define _noautoreq_perl Data::Uniqid UUID APR::UUID JSON DBD::Multi DBIC::SQL::Abstract
68c9fde7 61
28e72b45 62%description
ea7faab8
JB
63DBIx::Class is a SQL to OOP mapper, inspired by the Class::DBI
64framework, and meant to support compability with it, while
65restructuring the insides, and making it possible to support some new
66features like self-joins, distinct, group bys and more.
28e72b45 67
68It's currently considered EXPERIMENTAL - bring this near a production
ea7faab8
JB
69database at your own risk! The API is *not* fixed yet, although most
70of the primitives should be good for the future and any API changes
71will be posted to the mailing list before they're committed.
28e72b45 72
c133fc03
JR
73%description -l pl.UTF-8
74DBIx::Class to klasa odwzorowująca SQL na OOP, zainspirowana
75szkieletem Class::DBI, mająca obsługiwać kompatibilność z nim, ale
76restrukturyzując wnętrzności i umożliwiając obsługę niektórych nowych
77możliwości, takie jak "self-join", "distinct", "group by" i inne.
28e72b45 78
c133fc03
JR
79Ten moduł jest aktualnie uważany za EKSPERYMENTALNY - zbliżać go do
80baz produkcyjnych można tylko na własne ryzyko! API nie zostało
81jeszcze ustalone, choć większość prymitywów powinna być dobra na
82przyszłość i każda zmiana API jest wysyłana na listę dyskusyjną przed
ea7faab8 83zatwierdzeniem.
28e72b45 84
82abf19e 85%package -n perl-SQL-Translator-DBIx-Class
86Summary: DBIx::Class schema parser and file producer
b40db49d 87Summary(pl.UTF-8): Narzędzie do analizy schematów i tworzenia plików DBIx::Class
82abf19e 88Group: Development/Languages/Perl
89
90%description -n perl-SQL-Translator-DBIx-Class
91This package contains SQL::Translator (sqlfairy) parser for
8b743272
JB
92DBIx::Class::Schema objects and producer for DBIx::Class files.
93
c133fc03
JR
94%description -n perl-SQL-Translator-DBIx-Class -l pl.UTF-8
95Ten pakiet zawiera analizator SQL::Translator (sqlfairy) dla obiektów
96DBIx::Class::Schema oraz generator plików DBIx::Class.
82abf19e 97
28e72b45 98%prep
99%setup -q -n %{pdir}-%{pnam}-%{version}
f2ac0ba4 100%patch0 -p1
28e72b45 101
f2ac0ba4
JR
102# requires installed DBIx::Class of same version
103%{__mv} t/storage/dbic_pretty.t{,.disabled}
6de6ed6d 104
28e72b45 105%build
f2ac0ba4 106%{__perl} Makefile.PL \
209a3938 107 INSTALLDIRS=vendor
108%{__make}
28e72b45 109
209a3938 110%{?with_tests:%{__make} test}
28e72b45 111
112%install
113rm -rf $RPM_BUILD_ROOT
b1f5d72c 114install -d $RPM_BUILD_ROOT%{perl_vendorlib}/DBIx/Class/{Schema,ResultSet}
28e72b45 115
209a3938 116%{__make} install \
117 DESTDIR=$RPM_BUILD_ROOT
118
28e72b45 119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%files
123%defattr(644,root,root,755)
889ed4cc 124%doc Changes
b0cc6892 125%attr(755,root,root) %{_bindir}/*
28e72b45 126%{perl_vendorlib}/DBIx/*.pm
127%{perl_vendorlib}/DBIx/Class
d893cc20 128%{_mandir}/man3/DBIx*
8b598446 129%{_mandir}/man1/dbicadmin.*
82abf19e 130
131%files -n perl-SQL-Translator-DBIx-Class
132%defattr(644,root,root,755)
133%{perl_vendorlib}/SQL/Translator/Parser/*
134%{perl_vendorlib}/SQL/Translator/Producer/*
d893cc20 135%{_mandir}/man3/SQL*
This page took 0.171335 seconds and 4 git commands to generate.