]> git.pld-linux.org Git - packages/perl-DBIx-Class.git/blame - perl-DBIx-Class.spec
- up to 0.08196
[packages/perl-DBIx-Class.git] / perl-DBIx-Class.spec
CommitLineData
28e72b45 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir DBIx
7%define pnam Class
8Summary: DBIx::Class - Extensible and flexible object <-> relational mapper
b40db49d 9Summary(pl.UTF-8): DBIx::Class - rozszerzalne i elastyczne wiązanie obiektów <-> relacji
28e72b45 10Name: perl-DBIx-Class
31cbaf6a 11Version: 0.08196
12Release: 1
28e72b45 13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
2de26f35 15Source0: http://www.cpan.org/modules/by-module/DBIx/%{pdir}-%{pnam}-%{version}.tar.gz
31cbaf6a 16# Source0-md5: 9170d4fe95665189ed020c39d7370ca2
2de26f35 17URL: http://search.cpan.org/dist/DBIx-Class/
28e72b45 18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
c33ed24a 21BuildRequires: perl-Carp-Clan >= 6.0
31cbaf6a 22BuildRequires: perl-Class-Accessor-Grouped >= 0.10002
23BuildRequires: perl-Class-C3-Componentised >= 1.0009
c33ed24a 24BuildRequires: perl-Class-Inspector >= 1.24
31cbaf6a 25BuildRequires: perl-DBD-SQLite >= 1.29
c33ed24a 26BuildRequires: perl-DBI >= 1.605
b42b9f75 27BuildRequires: perl-Data-Dumper-Concise
d28fa658 28BuildRequires: perl-Data-Page >= 2.00
31cbaf6a 29BuildRequires: perl-Devel-Cycle >= 1.10
c33ed24a 30BuildRequires: perl-ExtUtils-MakeMaker >= 6.42
31BuildRequires: perl-File-Temp >= 0.22
32BuildRequires: perl-JSON-Any >= 1.18
33BuildRequires: perl-MRO-Compat >= 0.09
34BuildRequires: perl-Module-Find >= 0.06
35BuildRequires: perl-Path-Class >= 0.16
31cbaf6a 36BuildRequires: perl-SQL-Abstract >= 1.72
c33ed24a 37BuildRequires: perl-SQL-Abstract-Limit >= 0.13
31cbaf6a 38# optional. not accessible atm
39#BuildRequires: perl-SQL-Translator >= 0.11006
209a3938 40BuildRequires: perl-Scope-Guard >= 0.03
c33ed24a 41BuildRequires: perl-Sub-Name >= 0.04
42BuildRequires: perl-Test-Deep
31cbaf6a 43BuildRequires: perl-Test-Exception >= 0.31
44BuildRequires: perl-Test-Memory-Cycle
c33ed24a 45BuildRequires: perl-Test-Simple >= 0.92
46BuildRequires: perl-Test-Warn >= 0.21
31cbaf6a 47BuildRequires: perl-Text-CSV
28e72b45 48%endif
49BuildArch: noarch
50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
bb417167 52# Only APR::UUID is available in PLD. And if it was we would still
68c9fde7 53# need only one of Data::UUID, Data::Uniqid, APR::UUID or UUID at any
54# time to get full functionality
6de6ed6d 55%define _noautoreq 'perl(Data::Uniqid)' 'perl(UUID)' 'perl(APR::UUID)' 'perl(JSON)' 'perl(DBD::Multi)' 'perl(DBIC::SQL::Abstract)'
68c9fde7 56
28e72b45 57%description
ea7faab8
JB
58DBIx::Class is a SQL to OOP mapper, inspired by the Class::DBI
59framework, and meant to support compability with it, while
60restructuring the insides, and making it possible to support some new
61features like self-joins, distinct, group bys and more.
28e72b45 62
63It's currently considered EXPERIMENTAL - bring this near a production
ea7faab8
JB
64database at your own risk! The API is *not* fixed yet, although most
65of the primitives should be good for the future and any API changes
66will be posted to the mailing list before they're committed.
28e72b45 67
c133fc03
JR
68%description -l pl.UTF-8
69DBIx::Class to klasa odwzorowująca SQL na OOP, zainspirowana
70szkieletem Class::DBI, mająca obsługiwać kompatibilność z nim, ale
71restrukturyzując wnętrzności i umożliwiając obsługę niektórych nowych
72możliwości, takie jak "self-join", "distinct", "group by" i inne.
28e72b45 73
c133fc03
JR
74Ten moduł jest aktualnie uważany za EKSPERYMENTALNY - zbliżać go do
75baz produkcyjnych można tylko na własne ryzyko! API nie zostało
76jeszcze ustalone, choć większość prymitywów powinna być dobra na
77przyszłość i każda zmiana API jest wysyłana na listę dyskusyjną przed
ea7faab8 78zatwierdzeniem.
28e72b45 79
82abf19e 80%package -n perl-SQL-Translator-DBIx-Class
81Summary: DBIx::Class schema parser and file producer
b40db49d 82Summary(pl.UTF-8): Narzędzie do analizy schematów i tworzenia plików DBIx::Class
82abf19e 83Group: Development/Languages/Perl
84
85%description -n perl-SQL-Translator-DBIx-Class
86This package contains SQL::Translator (sqlfairy) parser for
8b743272
JB
87DBIx::Class::Schema objects and producer for DBIx::Class files.
88
c133fc03
JR
89%description -n perl-SQL-Translator-DBIx-Class -l pl.UTF-8
90Ten pakiet zawiera analizator SQL::Translator (sqlfairy) dla obiektów
91DBIx::Class::Schema oraz generator plików DBIx::Class.
82abf19e 92
28e72b45 93%prep
94%setup -q -n %{pdir}-%{pnam}-%{version}
95
6de6ed6d 96# SQL::Translator is FUBAR
97mv t/94versioning.t{,.fubar}
98
28e72b45 99%build
889ed4cc 100%{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"DBIx::Class", EXE_FILES=>[<script/*>])' \
209a3938 101 INSTALLDIRS=vendor
102%{__make}
28e72b45 103
209a3938 104%{?with_tests:%{__make} test}
28e72b45 105
106%install
107rm -rf $RPM_BUILD_ROOT
b1f5d72c 108install -d $RPM_BUILD_ROOT%{perl_vendorlib}/DBIx/Class/{Schema,ResultSet}
28e72b45 109
209a3938 110%{__make} install \
111 DESTDIR=$RPM_BUILD_ROOT
112
28e72b45 113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%files
117%defattr(644,root,root,755)
889ed4cc 118%doc Changes
b0cc6892 119%attr(755,root,root) %{_bindir}/*
28e72b45 120%{perl_vendorlib}/DBIx/*.pm
121%{perl_vendorlib}/DBIx/Class
d893cc20 122%{_mandir}/man3/DBIx*
8b598446 123%{_mandir}/man1/dbicadmin.*
82abf19e 124
125%files -n perl-SQL-Translator-DBIx-Class
126%defattr(644,root,root,755)
127%{perl_vendorlib}/SQL/Translator/Parser/*
128%{perl_vendorlib}/SQL/Translator/Producer/*
d893cc20 129%{_mandir}/man3/SQL*
This page took 0.099464 seconds and 4 git commands to generate.