]> git.pld-linux.org Git - packages/perl-DBICx-TestDatabase.git/blob - perl-DBICx-TestDatabase.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-DBICx-TestDatabase.git] / perl-DBICx-TestDatabase.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    DBICx
6 %define pnam    TestDatabase
7 Summary:        DBICx::TestDatabase - create a temporary database from a DBIx::Class::Schema
8 Summary(pl.UTF-8):      DBICx::TestDatabase - tworzy tymczasową bazę danych z DBIx::Class::Schema
9 Name:           perl-DBICx-TestDatabase
10 Version:        0.02
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://search.cpan.org/CPAN/authors/id/J/JR/JROCKWAY/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  e236d1a2bb4b07c70b35af0ae6e49415
17 URL:            http://search.cpan.org/dist/DBICx-TestDatabase/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-DBD-SQLite
22 BuildRequires:  perl-DBIx-Class
23 BuildRequires:  perl-SQL-Translator
24 BuildRequires:  perl-Test-use-ok
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module creates a temporary SQLite database, deploys your DBIC
31 schema, and then connects to it. This lets you easily test your DBIC
32 schema. Since you have a fresh database for every test, you don't have
33 to worry about cleaning up after your tests, ordering of tests
34 affecting failure, etc.
35
36 %description -l pl.UTF-8
37 Moduł ten tworzy tymczasową bazę danych SQLite, osadza schemat DBIC i
38 wtedy łaczy się z nim.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorlib}/DBICx/*.pm
63 %{perl_vendorlib}/DBICx/TestDatabase
64 %{_mandir}/man3/*
This page took 0.059297 seconds and 4 git commands to generate.