]> git.pld-linux.org Git - packages/perl-DBD-SQLite2.git/blob - perl-DBD-SQLite2.spec
perl 5.38.0 rebuild
[packages/perl-DBD-SQLite2.git] / perl-DBD-SQLite2.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    DBD
6 %define         pnam    SQLite2
7 Summary:        DBD::SQLite2 - Self Contained RDBMS in a DBI Driver (sqlite 2.x)
8 Summary(pl.UTF-8):      DBD::SQlite2 - Kompletny RDBMS zawarty w sterowniku DBI (sqlite 2.x)
9 Name:           perl-DBD-SQLite2
10 Version:        0.37
11 Release:        6
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  f05f60d8a54f0024abb3b3e39861ee3d
17 URL:            http://search.cpan.org/dist/DBD-SQLite2/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-DBI
22 %endif
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 DBD::SQLite2 is a DBI driver for SQLite database. SQLite is a public
27 domain RDBMS database engine that you can find at
28 <http://www.sqlite.org/>.
29
30 Rather than ask you to install SQLite first, DBD::SQLite2 includes the
31 entire thing in the distribution. So in order to get a fast
32 transaction capable RDBMS working for your perl project you simply
33 have to install this module, and nothing else.
34
35 This version uses older version of SQLite engine (2.x). To get a
36 newest one please use perl-DBD-SQLite.
37
38 %description -l pl.UTF-8
39 DBD::SQLite2 to sterownik DBI do baz danych SQLite. SQLite to silnik
40 relacyjnych baz danych na licencji public domain. Można go znaleźć pod
41 adresem <http://www.sqlite.org/>.
42
43 DBD::SQLite2 zawiera w sobie cały silnik bazy danych. Dzięki temu aby
44 otrzymać działający RDBMS dostępny z poziomu Perla nie trzeba
45 instalować żadnych innych pakietów.
46
47 Ta wersja korzysta ze starszej wersji silnika SQLite (2.x). Aby użyć
48 nowszej wersji należy zainstalować pakiet perl-DBD-SQLite.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52
53 # not real test
54 mv t/ak-dbd.t{,est}
55
56 %build
57 %{__perl} Makefile.PL \
58         INSTALLDIRS=vendor
59
60 %{__make} \
61         CC="%{__cc}" \
62         OPTIMIZE="%{rpmcflags}"
63
64 %{?with_tests:%{__make} test}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/DBD/getsqlite.pl
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc Changes README
80 %{perl_vendorarch}/DBD/SQLite2.pm
81 %dir %{perl_vendorarch}/auto/DBD/SQLite2
82 %attr(755,root,root) %{perl_vendorarch}/auto/DBD/SQLite2/SQLite2.so
83 %{_mandir}/man3/DBD*
This page took 0.118829 seconds and 4 git commands to generate.