]> git.pld-linux.org Git - packages/perl-DBD-PgPP.git/blob - perl-DBD-PgPP.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-DBD-PgPP.git] / perl-DBD-PgPP.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (requires database connection)
4 #
5 %define         pdir    DBD
6 %define         pnam    PgPP
7 Summary:        Pure Perl PostgresSQL driver for DBI
8 Summary(pl.UTF-8):      Czysto perlowy sterownik do PostgresSQL-a dla DBI
9 Name:           perl-DBD-PgPP
10 Version:        0.08
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/DBD/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  0993870ecda306a619a5a10825e7bd29
17 URL:            http://search.cpan.org/dist/DBD-PgPP/
18 BuildRequires:  perl-DBI
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 DBD::PgPP is a Pure Perl client interface for the PostgreSQL database.
26 This module implements the PostgreSQL client/server network protocol,
27 so you don't need an external PostgreSQL client library like "libpq"
28 for it to work. That means you can connect to a PostgreSQL server from
29 operating systems to which PostgreSQL has not been ported.
30
31 %description -l pl.UTF-8
32 DBD::PgPP to czysto perlowy interfejs kliencki do bazy danych
33 PostgreSQL. Ten moduł implementuje protokół sieciowy klient-serwer
34 PostgreSQL-a, więc nie wymaga do działania zewnętrznej biblioteki
35 klienckiej typu libpq. Oznacza to, że można się łączyć z serwerem
36 PostgreSQL z systemów operacyjnych, na które PostgreSQL nie został
37 sportowany.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 # Needed to be set for tests:
48 #PG_TEST_DB=<database>
49 #PG_TEST_USER=<user>
50 #PG_TEST_PASS=<password>
51 #PG_TEST_HOST=<hostname>*
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README
66 %{perl_vendorlib}/DBD/PgPP.pm
67 %{_mandir}/man[13]/*
This page took 0.074819 seconds and 4 git commands to generate.