]> git.pld-linux.org Git - packages/perl-Crypt-Twofish2.git/blob - perl-Crypt-Twofish2.spec
perl 5.38.0 rebuild
[packages/perl-Crypt-Twofish2.git] / perl-Crypt-Twofish2.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    Twofish2
7 Summary:        Crypt::Twofish2 - Crypt::CBC compliant Twofish encryption Perl module
8 Summary(pl.UTF-8):      Crypt::Twofish2 - perlowy moduł szyfru Twofish zgodny z Crypt::CBC
9 Name:           perl-Crypt-Twofish2
10 Version:        1.02
11 Release:        15
12 License:        GPL v2
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  28efe17baac40c14914912bb3e5932b5
16 URL:            http://search.cpan.org/dist/Crypt-Twofish2/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This module implements the Twofish cipher in a less braindamaged
23 (read: slow and ugly) way than the existing "Crypt::Twofish" module.
24 Although it is "Crypt::CBC" compliant you usually gain nothing by
25 using that module (except generality), since "Crypt::Twofish2" can
26 work in either ECB or CBC mode.
27
28 %description -l pl.UTF-8
29 Ten moduł jest implementacją szyfru Twofish w mniej debilny (powolny
30 i paskudny) sposób niż moduł Crypt::Twofish. Pomimo tego, że jest
31 zgodny z Crypt::CBC, nie ma potrzeby używania tamtego modułu, ponieważ
32 Crypt::Twofish2 może działać zarówno w trybie ECB jak i CBC.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorarch}/Crypt/Twofish2.pm
59 %dir %{perl_vendorarch}/auto/Crypt/Twofish2
60 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Twofish2/*.so
61 %{_mandir}/man3/*
This page took 0.091941 seconds and 3 git commands to generate.