]> git.pld-linux.org Git - packages/perl-Crypt-Twofish.git/blob - perl-Crypt-Twofish.spec
perl 5.38.0 rebuild
[packages/perl-Crypt-Twofish.git] / perl-Crypt-Twofish.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    Twofish
7 Summary:        Crypt::Twofish Perl module - the Twofish encryption algorithm
8 Summary(pl.UTF-8):      Moduł Perla Crypt::Twofish - algorytm szyfrowania Twofish
9 Name:           perl-Crypt-Twofish
10 Version:        2.17
11 Release:        6
12 License:        Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  bb6e7ec9ff6db6aea27dce7175a852e2
16 Patch0:         no-dot-in-inc.patch
17 URL:            http://search.cpan.org/dist/Crypt-Twofish/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module implements Twofish encryption. It supports the Crypt::CBC
24 interface. Twofish is a 128-bit symmetric block cipher with a variable
25 length (128, 192, or 256-bit) key, developed by Counterpane Labs. It
26 is unpatented and free for all uses, as described at
27 <http://www.counterpane.com/twofish.html>.
28
29 %description -l pl.UTF-8
30 Ten moduł jest implementacją szyfrowania Twofish. Obsługuje interfejs
31 Crypt::CBC. Twofish jest 128-bitowym symetrycznym szyfrem blokowym ze
32 zmienną długością klucza (128, 192 lub 256 bitów), opracowanym przez
33 Counterpane Labs. Nie jest opatentowany i można go swobodnie używać
34 do dowolnych celów, zgodnie z opisem pod adresem
35 <http://www.counterpane.com/twofish.html>.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39 %patch0 -p1
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorarch}/Crypt/Twofish.pm
63 %dir %{perl_vendorarch}/auto/Crypt/Twofish
64 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Twofish/*.so
65 %{_mandir}/man3/*
This page took 0.129245 seconds and 4 git commands to generate.