]> git.pld-linux.org Git - packages/perl-Crypt-Random.git/blob - perl-Crypt-Random.spec
- license fixes and unification
[packages/perl-Crypt-Random.git] / perl-Crypt-Random.spec
1
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    Random
8 Summary:        Crypt::Random - cryptographically secure, true random number generator
9 Summary(pl):    Crypt::Random - bezpieczny kryptograficznie, prawdziwy generator liczb losowych
10 Name:           perl-Crypt-Random
11 Version:        1.13
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  7e01bb787041c52557698a03fd801098
18 %if %{with tests}
19 BuildRequires:  perl-Class-Loader >= 2.00
20 BuildRequires:  perl-Math-Pari >= 2.001804
21 %endif
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  perl-devel >= 5.6.1
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Crypt::Random is an interface module to the /dev/random device found
29 on most modern Unix systems. The /dev/random driver gathers
30 environmental noise from various non-deterministic sources including
31 inter-keyboard timings and inter-interrupt timings that occur within
32 the operating system environment.
33
34 %description -l pl
35 Modu³ Perla Crypt::Random stanowi interfejs do urz±dzenia /dev/random
36 znajduj±cego siê w wiêkszo¶ci wspó³czesnych systemów uniksowych.
37 Sterownik /dev/random gromadzi szum pochodz±cy z ró¿nych
38 niedeterministycznych ¼róde³, w³±czaj±c w to: przebiegi czasowe
39 klawiatury i przerwañ wystêpuj±ce w systemie operacyjnym.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %attr(755,root,root) %{_bindir}/*
64 %{perl_vendorlib}/Crypt/Random.pm
65 %{perl_vendorlib}/Crypt/Random
66 #%%{perl_vendorlib}/Crypt/Random/Generator.pm
67 %{_mandir}/man3/*
This page took 0.284531 seconds and 3 git commands to generate.