]> git.pld-linux.org Git - packages/perl-Crypt-RSA.git/blob - perl-Crypt-RSA.spec
- generic URL
[packages/perl-Crypt-RSA.git] / perl-Crypt-RSA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    RSA
8 Summary:        Crypt::RSA Perl module - RSA public-key cryptosystem
9 Summary(pl.UTF-8):      Moduł Perla Crypt::RSA - system kryptograficzny klucza publicznego RSA
10 Name:           perl-Crypt-RSA
11 Version:        1.58
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  fb0eb5f47f42eb8737e1ecfa28ed4523
18 URL:            http://search.cpan.org/dist/Crypt-RSA/
19 %if %{with tests}
20 BuildRequires:  perl-Convert-ASCII-Armour
21 BuildRequires:  perl-Class-Loader >= 2.00
22 BuildRequires:  perl-Crypt-Blowfish
23 BuildRequires:  perl-Crypt-CBC
24 BuildRequires:  perl-Crypt-Primes >= 0.38
25 BuildRequires:  perl-Crypt-Random >= 0.33
26 BuildRequires:  perl-Data-Buffer
27 BuildRequires:  perl-Digest-MD2
28 BuildRequires:  perl-Digest-MD5
29 BuildRequires:  perl-Digest-SHA1
30 BuildRequires:  perl-Math-Pari >= 2.001804
31 BuildRequires:  perl-Sort-Versions
32 BuildRequires:  perl-Tie-EncryptedHash
33 %endif
34 BuildRequires:  perl-devel >= 1:5.8.0
35 BuildRequires:  rpm-perlprov >= 4.1-13
36 Requires:       perl-Class-Loader >= 2.00
37 Requires:       perl-Crypt-Primes >= 0.38
38 Requires:       perl-Crypt-Random >= 0.33
39 Requires:       perl-Math-Pari >= 2.001804
40 BuildArch:      noarch
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Crypt::RSA is a pure-perl, cleanroom implementation of the RSA
45 public-key cryptosystem.
46
47 %description -l pl.UTF-8
48 Moduł Crypt::RSA jest czysto perlową implementacją systemu
49 kryptograficznego klucza publicznego RSA.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make}
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes TODO extradocs/*
73 %{perl_vendorlib}/Crypt/RSA.pm
74 %{perl_vendorlib}/Crypt/RSA
75 %{_mandir}/man3/*
This page took 0.088087 seconds and 4 git commands to generate.