]> git.pld-linux.org Git - packages/perl-Crypt-RSA.git/blob - perl-Crypt-RSA.spec
dfa201c0b7c2b6abdc1ef9fa6d43f4abd097dc11
[packages/perl-Crypt-RSA.git] / perl-Crypt-RSA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    RSA
8 Summary:        Crypt::RSA Perl module - RSA public-key cryptosystem
9 Summary(pl.UTF-8):      Moduł Perla Crypt::RSA - system kryptograficzny klucza publicznego RSA
10 Name:           perl-Crypt-RSA
11 Version:        1.99
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  f675a07810d735e99d7894338aba8e87
18 URL:            http://search.cpan.org/dist/Crypt-RSA/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Class-Loader >= 2.00
23 BuildRequires:  perl-Convert-ASCII-Armour
24 BuildRequires:  perl-Crypt-Blowfish
25 BuildRequires:  perl-Crypt-CBC
26 BuildRequires:  perl-Crypt-Primes >= 0.38
27 BuildRequires:  perl-Crypt-Random >= 0.34
28 BuildRequires:  perl-Data-Buffer
29 BuildRequires:  perl-Digest-MD2
30 BuildRequires:  perl-Math-Pari >= 2.001804
31 BuildRequires:  perl-Sort-Versions
32 BuildRequires:  perl-Tie-EncryptedHash
33 BuildRequires:  perl-Digest-SHA1
34 %endif
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Crypt::RSA is a pure-perl, cleanroom implementation of the RSA
40 public-key cryptosystem.
41
42 %description -l pl.UTF-8
43 Moduł Crypt::RSA jest czysto perlową implementacją systemu
44 kryptograficznego klucza publicznego RSA.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes README TODO
68 %{perl_vendorlib}/Crypt/*.pm
69 %{perl_vendorlib}/Crypt/RSA
70 %{_mandir}/man3/*
This page took 0.063227 seconds and 2 git commands to generate.