]> git.pld-linux.org Git - packages/perl-Crypt-RSA.git/blob - perl-Crypt-RSA.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Crypt-RSA.git] / perl-Crypt-RSA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    RSA
7 Summary:        Crypt::RSA Perl module - RSA public-key cryptosystem
8 Summary(pl.UTF-8):      Moduł Perla Crypt::RSA - system kryptograficzny klucza publicznego RSA
9 Name:           perl-Crypt-RSA
10 Version:        1.99
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  f675a07810d735e99d7894338aba8e87
17 URL:            http://search.cpan.org/dist/Crypt-RSA/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Class-Loader >= 2.00
22 BuildRequires:  perl-Convert-ASCII-Armour
23 BuildRequires:  perl-Crypt-Blowfish
24 BuildRequires:  perl-Crypt-CBC
25 BuildRequires:  perl-Crypt-Primes >= 0.38
26 BuildRequires:  perl-Crypt-Random >= 0.34
27 BuildRequires:  perl-Data-Buffer
28 BuildRequires:  perl-Digest-MD2
29 BuildRequires:  perl-Math-Pari >= 2.001804
30 BuildRequires:  perl-Sort-Versions
31 BuildRequires:  perl-Tie-EncryptedHash
32 BuildRequires:  perl-Digest-SHA1
33 %endif
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Crypt::RSA is a pure-perl, cleanroom implementation of the RSA
39 public-key cryptosystem.
40
41 %description -l pl.UTF-8
42 Moduł Crypt::RSA jest czysto perlową implementacją systemu
43 kryptograficznego klucza publicznego RSA.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README TODO
67 %{perl_vendorlib}/Crypt/*.pm
68 %{perl_vendorlib}/Crypt/RSA
69 %{_mandir}/man3/*
This page took 1.10259 seconds and 3 git commands to generate.