]> git.pld-linux.org Git - packages/perl-Crypt-RC5.git/blob - perl-Crypt-RC5.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Crypt-RC5.git] / perl-Crypt-RC5.spec
1 %define         pdir    Crypt
2 %define         pnam    RC5
3 Summary:        Crypt::RC5 Perl module - RC5 encryption algorithm implementation
4 Summary(pl.UTF-8):      Moduł Perla Crypt::RC5 - implementacja algorytmu szyfrowania RC5
5 Name:           perl-Crypt-RC5
6 Version:        2.00
7 Release:        4
8 # same as perl
9 License:        GPL v1+ or Artistic
10 Group:          Development/Languages/Perl
11 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
12 # Source0-md5:  79649f6eba759a4415513a8512eaeb21
13 URL:            http://search.cpan.org/dist/Crypt-RC5/
14 BuildRequires:  perl-devel >= 1:5.8.0
15 BuildRequires:  rpm-perlprov >= 4.1-13
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Perl implementation of the RC5 algorithm. RC5 is a fast block cipher
21 designed by Ronald Rivest for RSA Data Security (now RSA Security) in
22 1994. It is a parameterized algorithm with a variable block size, a
23 variable key size, and a variable number of rounds. This particular
24 implementation is 32 bit. As such, it is suggested that a minimum of
25 12 rounds be performed.
26
27 %description -l pl.UTF-8
28 Implementacja algorytmu RC5 w Perlu. RC5 jest szybkim szyfrem blokowym
29 opracowanym przez Ronalda Rivesta dla RSA Data Security (teraz RSA
30 Security) w 1994 roku. Jest to sparametryzowany algorytm ze zmiennym
31 rozmiarem bloku, zmiennym rozmiarem klucza i zmienną liczbą kroków. Ta
32 konkretna implementacja jest 32-bitowa. Sugeruje się wykonywanie
33 minimum 12 kroków.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42 %{__make} test
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorlib}/Crypt/RC5.pm
57 %{_mandir}/man3/*
This page took 0.090989 seconds and 4 git commands to generate.