]> git.pld-linux.org Git - packages/perl-Crypt-Primes.git/blob - perl-Crypt-Primes.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Crypt-Primes.git] / perl-Crypt-Primes.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Crypt
6 %define         pnam    Primes
7 Summary:        Crypt::Primes - provable prime number generator suitable for cryptographic applications
8 Summary(pl.UTF-8):      Crypt::Primes - wiarygodny generator liczb pierwszych, nadający się do aplikacji kryptograficznych
9 Name:           perl-Crypt-Primes
10 Version:        0.50
11 Release:        5
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  041947b9645142615d687b89cf2e1a7b
17 URL:            http://search.cpan.org/dist/Crypt-Primes/
18 BuildRequires:  perl-Crypt-Random >= 0.33
19 BuildRequires:  perl-Math-Pari >= 2.001804
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Crypt::Primes module implements in pure Perl Ueli Maurer's algorithm
27 for generating large provable primes and secure parameters for
28 public-key cryptosystems. The generated primes are almost uniformly
29 distributed over the set of primes of the specified bitsize and
30 expected time for generation is less than the time required for
31 generating a pseudo-prime of the same size with Miller-Rabin tests.
32 Detailed description and running time analysis of the algorithm can be
33 found in Maurer's paper (Fast Generation of Prime Numbers and Secure
34 Public-Key Cryptographic Parameters, Ueli Maurer (1994)).
35
36 %description -l pl.UTF-8
37 Moduł Crypt::Primes jest czysto perlową implementacją algorytmu
38 generacji dużych wiarygodnych liczb losowych Ueli Maurera oraz
39 generacji bezpiecznych parametrów dla systemów kryptograficznych
40 korzystających z klucza publicznego. Wygenerowane liczby pierwsze są
41 rozłożone niemal jednostajnie w zbiorze liczb pierwszych o zadanym
42 rozmiarze bitowym a oczekiwany czas generacji jest krótszy niż dla
43 generacji liczb pseudo-pierwszych o tym samym rozmiarze za pomocą
44 testów Millera-Rabina. Szczegółowy opis i analizy czasowe algorytmu
45 można znaleźć z artykule Maurera (Fast Generation of Prime Numbers and
46 Secure Public-Key Cryptographic Parameters, Ueli Maurer (1994))
47
48 - wiarygodny generator liczb pierwszych, nadający się dla aplikacji
49   kryptograficznych.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make}
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes README
73 %attr(755,root,root) %{_bindir}/*
74 %{perl_vendorlib}/Crypt/Primes.pm
75 %{_mandir}/man[13]/*
This page took 0.090053 seconds and 4 git commands to generate.